summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-05-24 02:21:19 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-05-24 02:21:19 +0000
commit8f74321b564758b3e64a85703e71463226cd6a44 (patch)
tree4e34696aef5add53e0854f61fe0bdae8ff844487 /net-libs/libnids/libnids-1.21.ebuild
parentdead, use ccache/distcc (diff)
downloadhistorical-8f74321b564758b3e64a85703e71463226cd6a44.tar.gz
historical-8f74321b564758b3e64a85703e71463226cd6a44.tar.bz2
historical-8f74321b564758b3e64a85703e71463226cd6a44.zip
1.21 version bump for bug 133722. Thanks to Sebastien Raveau <sebastien.raveau at gmail dot com>
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-libs/libnids/libnids-1.21.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.21.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/libnids/libnids-1.21.ebuild b/net-libs/libnids/libnids-1.21.ebuild
new file mode 100644
index 000000000000..d48a67e52431
--- /dev/null
+++ b/net-libs/libnids/libnids-1.21.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.21.ebuild,v 1.1 2006/05/24 02:21:19 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="emulates the IP stack of Linux 2.0.x and offers IP defragmentation, TCP stream assembly and TCP port scan detection."
+HOMEPAGE="http://libnids.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.20-chksum.c-ebx.patch
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install_prefix="${D}" install || die "make install failed"
+ dodoc CHANGES CREDITS MISC README
+}