summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-07 12:42:34 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-07 12:42:34 +0000
commita7241dc3055da6314cc43535e8dc95bf67116173 (patch)
tree398102400d6bea3805ac81c8771c716e0e254992 /net-libs/libktorrent
parentVersion bump. Fixes #349108 (package.accept_keywords support) and #349207 ('*... (diff)
downloadhistorical-a7241dc3055da6314cc43535e8dc95bf67116173.tar.gz
historical-a7241dc3055da6314cc43535e8dc95bf67116173.tar.bz2
historical-a7241dc3055da6314cc43535e8dc95bf67116173.zip
Fix src_uri calculation per bug #350927. Thanks to Lars (Poly-C) for the patch.
Package-Manager: portage-2.2.0_alpha13/cvs/Linux x86_64
Diffstat (limited to 'net-libs/libktorrent')
-rw-r--r--net-libs/libktorrent/ChangeLog7
-rw-r--r--net-libs/libktorrent/Manifest4
-rw-r--r--net-libs/libktorrent/libktorrent-1.0.5.3.ebuild4
3 files changed, 10 insertions, 5 deletions
diff --git a/net-libs/libktorrent/ChangeLog b/net-libs/libktorrent/ChangeLog
index a1a47e3f057d..d01c01ffc6db 100644
--- a/net-libs/libktorrent/ChangeLog
+++ b/net-libs/libktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libktorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.8 2011/01/06 21:56:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.9 2011/01/07 12:42:34 scarabeus Exp $
+
+ 07 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libktorrent-1.0.5.3.ebuild:
+ Fix src_uri calculation per bug #350927. Thanks to Lars (Poly-C) for the
+ patch.
*libktorrent-1.0.5.3 (06 Jan 2011)
diff --git a/net-libs/libktorrent/Manifest b/net-libs/libktorrent/Manifest
index 4276014b69fe..4afdac2d6957 100644
--- a/net-libs/libktorrent/Manifest
+++ b/net-libs/libktorrent/Manifest
@@ -1,4 +1,4 @@
DIST libktorrent-1.0.5-3.tar.bz2 872674 RMD160 5ab34f1e2c011442bd959c37698982747d77980c SHA1 7e0551d731e18075eae8d8e92f9e5d5d26cc3f18 SHA256 5b1d8cb866c5837960241588eaf227dd364c31a2f35be889f69cd7ce47bc836c
-EBUILD libktorrent-1.0.5.3.ebuild 1421 RMD160 71c0c7eec2f12220664e6c9ea896494879da3f74 SHA1 993d30964d15d9604556da8addfc13b1b3837d25 SHA256 abce8efa027ab63cdfa1a589107bcc1237ece9717cd0bf178469d88f972ab347
-MISC ChangeLog 1555 RMD160 f2e8801147f55fa8bb1a41a415e8d7db97c92983 SHA1 f9958459e3ab32c5361216c486cda8743fbfc12f SHA256 59fefeb68669341de3d3d3ed069bcd0b25e4ce0abf5c74935837aaedfa0ce974
+EBUILD libktorrent-1.0.5.3.ebuild 1429 RMD160 c8ea038598c580c9ad5bbe6bc6c203b8d5c929ba SHA1 99b641c9d72988e189bd400f508672bcc7423342 SHA256 6b43a1ce241183e8957f9e66d8e435e0da7498578773f17dfbcdb62f70e26f15
+MISC ChangeLog 1725 RMD160 2bc870cca2536f1e9d8bcd524cf1cd7177fc5e6b SHA1 e22689e63d054378c8ca38bfaeebc8b201a2d4af SHA256 9a1f2d2aa2a2ba00c245a7ea97ab2a1b9b9f0ca8393b72b8a1c1d929a9585c80
MISC metadata.xml 157 RMD160 09fb7b798f3f68127626e97c69e5215a0513ecbb SHA1 d5ffebb2f4248fc8f65ab21c3af6e4f5dbf8bf6e SHA256 01f6fa4357ce08e8b0f7900a51fa78c7f060fefc7c7da98acaec1e283dd59892
diff --git a/net-libs/libktorrent/libktorrent-1.0.5.3.ebuild b/net-libs/libktorrent/libktorrent-1.0.5.3.ebuild
index b47ce09f18c1..6c6a99d7a109 100644
--- a/net-libs/libktorrent/libktorrent-1.0.5.3.ebuild
+++ b/net-libs/libktorrent/libktorrent-1.0.5.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.0.5.3.ebuild,v 1.1 2011/01/06 21:56:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.0.5.3.ebuild,v 1.2 2011/01/07 12:42:34 scarabeus Exp $
EAPI=3
KMNAME="extragear/network"
if [[ ${PV} != 9999* ]]; then
inherit versionator
# upstream likes to skip that _ in beta releases
- KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_after_major_version)
+ KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_version_component_range 2-3)
MY_PV="${PV/_/}"
MY_PV=$(replace_version_separator 3 '-' ${MY_PV}) # ZOMGHACK REMOVE ME NEXT TIME
MY_P="${PN}-${MY_PV}"