summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-04-22 08:07:40 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-04-22 08:07:40 +0000
commitf237aea97983427becf00a857f967bfb6bce8d59 (patch)
treeeebb9a75d5de69f3dc87eaf53b7a814fc9cd8679 /net-im/silc-client
parentVersion bump to solve buffer overflow and other bugs. (diff)
downloadhistorical-f237aea97983427becf00a857f967bfb6bce8d59.tar.gz
historical-f237aea97983427becf00a857f967bfb6bce8d59.tar.bz2
historical-f237aea97983427becf00a857f967bfb6bce8d59.zip
Version bump to solve buffer overflow and other bugs.
Diffstat (limited to 'net-im/silc-client')
-rw-r--r--net-im/silc-client/Manifest4
-rw-r--r--net-im/silc-client/files/digest-silc-client-0.9.12.11
-rw-r--r--net-im/silc-client/silc-client-0.9.12.1.ebuild60
3 files changed, 63 insertions, 2 deletions
diff --git a/net-im/silc-client/Manifest b/net-im/silc-client/Manifest
index a5b2cb461e4e..9c514af7c39b 100644
--- a/net-im/silc-client/Manifest
+++ b/net-im/silc-client/Manifest
@@ -1,5 +1,5 @@
-MD5 676f5da21f4fe67707ee4d4b34d35c77 silc-client-0.9.12.1.ebuild 1750
+MD5 a84b06341841f279a99add99cee361e3 silc-client-0.9.12.1.ebuild 1753
MD5 bccd496b5f226b555131ff60de1fdc21 silc-client-0.9.11.ebuild 1350
-MD5 465b8d8769437bfab19784997a77f963 ChangeLog 1472
+MD5 c2e7629cdbd9063732eebea66d90944e ChangeLog 1657
MD5 fb190d39f5c608735fb3650027e4499f files/digest-silc-client-0.9.11 72
MD5 c0de3b6dda921ad76210c11a653f40ee files/digest-silc-client-0.9.12.1 74
diff --git a/net-im/silc-client/files/digest-silc-client-0.9.12.1 b/net-im/silc-client/files/digest-silc-client-0.9.12.1
new file mode 100644
index 000000000000..1caf0a29f8da
--- /dev/null
+++ b/net-im/silc-client/files/digest-silc-client-0.9.12.1
@@ -0,0 +1 @@
+MD5 0ea94745b3036e4dcc18f6e8e54bbaa5 silc-client-0.9.12.1.tar.bz2 1529756
diff --git a/net-im/silc-client/silc-client-0.9.12.1.ebuild b/net-im/silc-client/silc-client-0.9.12.1.ebuild
new file mode 100644
index 000000000000..df7b697351c8
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.9.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.12.1.ebuild,v 1.1 2003/04/22 08:07:37 absinthe Exp $
+
+DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+IUSE="ipv6 perl socks5"
+
+DEPEND="=dev-libs/glib-1.2*
+ perl? ( dev-lang/perl )
+ socks5? ( net-misc/dante )
+ sys-libs/ncurses"
+
+src_compile() {
+ local myconf
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+ use socks5 && myconf="${myconf} --with-socks5"
+
+ econf \
+ --prefix=/usr \
+ --datadir=/usr/share/${PN} \
+ --with-datadir=/usr/share/${PN} \
+ --with-docdir=/usr/share/doc/${PN} \
+ --with-helpdir=/usr/share/${PN}/help \
+ --with-logsdir=/var/log/${PN} \
+ --with-simdir=/usr/lib/${PN} \
+ --with-ncurses \
+ --without-silcd
+ ${myconf} \
+ || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr/lib"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ mv ${D}/usr/libsilc.a ${D}/usr/lib/
+ mv ${D}/usr/libsilcclient.a ${D}/usr/lib/
+ mv ${D}/usr/libsilcclient.la ${D}/usr/lib/
+ mv ${D}/usr/libsilc.la ${D}/usr/lib/
+ rmdir ${D}/usr/share/silc/
+ rmdir ${D}/usr/include
+}