summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-04-23 12:24:11 +0000
committerDon Seiler <rizzo@gentoo.org>2004-04-23 12:24:11 +0000
commita5256d49f397823c01974b9f57727385b2a23066 (patch)
treed25327c46297e70da2cd01aaa8771d4b91c964c0 /net-im/gaim
parentVersion bump (diff)
downloadhistorical-a5256d49f397823c01974b9f57727385b2a23066.tar.gz
historical-a5256d49f397823c01974b9f57727385b2a23066.tar.bz2
historical-a5256d49f397823c01974b9f57727385b2a23066.zip
Version bump
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/ChangeLog8
-rw-r--r--net-im/gaim/Manifest5
-rw-r--r--net-im/gaim/files/digest-gaim-0.771
-rw-r--r--net-im/gaim/files/gaim-0.77-c99.patch140
-rw-r--r--net-im/gaim/gaim-0.77.ebuild122
5 files changed, 274 insertions, 2 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 4e7e4c2f51dc..9a41246a1c0d 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.164 2004/04/22 14:07:52 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.165 2004/04/23 12:24:11 rizzo Exp $
+
+*gaim-0.77 (23 Apr 2004)
+
+ 23 Apr 2004; Don Seiler <rizzo@gentoo.org>; +files/gaim-0.77-c99.patch,
+ +gaim-0.77.ebuild:
+ Version bump
22 Apr 2004; Travis Tilley <lv@gentoo.org> gaim-0.75-r10.ebuild:
stable on amd64
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 01d9768683d3..1fc0230b7cde 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,10 +1,13 @@
MD5 0e7e912e84a644bb51137bdb43ad24f4 gaim-0.76-r2.ebuild 4024
+MD5 87d95a81dd3a83e57564f6cfb538f77d gaim-0.77.ebuild 3930
MD5 3f83632c7a4343c69d51cbcff885c441 gaim-0.75-r10.ebuild 3673
-MD5 53b032db7c2c0fb34ce93863d4e0df05 ChangeLog 26966
+MD5 f3a63237b5ea4728df57b605937db3dd ChangeLog 27106
MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
MD5 ff7da91fdc2d63cb9ade430cbedeac98 gaim-0.75-r8.ebuild 3498
MD5 4989dc76d941288934c783f52931762d files/gaim-0.75-static-prpls.patch 3710
+MD5 4bc83ad48d260db208fcae372c2bb291 files/digest-gaim-0.77 63
MD5 227bbaed75eb1c3130c70dfd919bd148 files/gaim-0.76-spellchk.diff 694
+MD5 3a5e6167d13c4a44a8618c12629d777e files/gaim-0.77-c99.patch 4790
MD5 a714a5babbb4387f5a5516f75548528a files/gaim-0.76cvs-yahoo-misc-fixes-1.diff 3105
MD5 68525b8389e356a5d05d531b84fb1ada files/gaim-0.74-gnome-url-handler.patch 1854
MD5 8e59c66d91c79a3323e350a9c41d4ecb files/gevolution.h 2745
diff --git a/net-im/gaim/files/digest-gaim-0.77 b/net-im/gaim/files/digest-gaim-0.77
new file mode 100644
index 000000000000..9b4f6738da22
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.77
@@ -0,0 +1 @@
+MD5 d2ac2eb75e5e27f7fddf2a7dc19eb045 gaim-0.77.tar.bz2 3709914
diff --git a/net-im/gaim/files/gaim-0.77-c99.patch b/net-im/gaim/files/gaim-0.77-c99.patch
new file mode 100644
index 000000000000..0c9b72a8fe1b
--- /dev/null
+++ b/net-im/gaim/files/gaim-0.77-c99.patch
@@ -0,0 +1,140 @@
+--- /src/protocols/novell/nmcontact.c 2004/04/17 18:29:20 1.2
++++ /src/protocols/novell/nmcontact.c 2004/04/23 06:14:15 1.3
+@@ -701,11 +701,11 @@
+ void
+ nm_folder_remove_contact(NMFolder * folder, NMContact * contact)
+ {
++ GSList *node = folder->contacts;
++
+ if (folder == NULL || contact == NULL)
+ return;
+
+- GSList *node = folder->contacts;
+-
+ while (node) {
+ if (contact->id == ((NMContact *) (node->data))->id) {
+ folder->contacts = g_slist_remove(folder->contacts, node->data);
+--- /src/protocols/novell/nmuser.c 21 Apr 2004 21:01:16 -0000 1.3
++++ /src/protocols/novell/nmuser.c 23 Apr 2004 09:13:40 -0000
+@@ -50,10 +50,12 @@ NMUser *
+ nm_initialize_user(const char *name, const char *server_addr,
+ int port, gpointer data, nm_event_cb event_callback)
+ {
++ NMUser *user;
++
+ if (name == NULL || server_addr == NULL || event_callback == NULL)
+ return NULL;
+
+- NMUser *user = g_new0(NMUser, 1);
++ user = g_new0(NMUser, 1);
+
+ user->conn = g_new0(NMConn, 1);
+
+@@ -1647,11 +1649,12 @@ char *
+ nm_typed_to_dotted(const char *typed)
+ {
+ unsigned i = 0, j = 0;
++ char *dotted;
+
+ if (typed == NULL)
+ return NULL;
+
+- char *dotted = g_new0(char, strlen(typed));
++ dotted = g_new0(char, strlen(typed));
+
+ do {
+
+--- /src/protocols/novell/nmuser.c 21 Apr 2004 21:01:16 -0000 1.3
++++ /src/protocols/novell/nmuser.c 23 Apr 2004 09:28:59 -0000
+@@ -1690,6 +1690,7 @@ _update_contact_list(NMUser * user, NMFi
+ {
+ NMField *list, *cursor, *locate;
+ gint objid1;
++ gpointer item;
+ NMContact *contact;
+ NMFolder *folder;
+
+@@ -1713,8 +1714,7 @@ _update_contact_list(NMUser * user, NMFi
+ nm_locate_field(NM_A_SZ_OBJECT_ID, (NMField *) cursor->value);
+ if (locate != NULL && locate->value != 0) {
+ objid1 = atoi((char *) locate->value);
+- gpointer item =
+- nm_folder_find_item_by_object_id(user->root_folder, objid1);
++ item = nm_folder_find_item_by_object_id(user->root_folder, objid1);
+ if (item != NULL) {
+ if (cursor->method == NMFIELD_METHOD_ADD) {
+ if (g_ascii_strcasecmp(cursor->tag, NM_A_FA_CONTACT) == 0) {
+--- /src/protocols/novell/novell.c 22 Apr 2004 01:53:15 -0000 1.9
++++ /src/protocols/novell/novell.c 23 Apr 2004 09:41:23 -0000
+@@ -893,6 +893,7 @@ _add_contacts_to_gaim_blist(NMUser * use
+ NMUserRecord *user_record = NULL;
+ NMContact *contact = NULL;
+ GaimBuddy *buddy = NULL;
++ GaimGroup *group = NULL;
+ NMERR_T cnt = 0, i;
+ const char *text = NULL;
+ const char *name = NULL;
+@@ -912,7 +913,7 @@ _add_contacts_to_gaim_blist(NMUser * use
+ nm_contact_get_display_name(contact));
+
+ /* Does the Gaim group exist already? */
+- GaimGroup *group = gaim_find_group(nm_folder_get_name(folder));
++ group = gaim_find_group(nm_folder_get_name(folder));
+
+ if (group == NULL) {
+ group = gaim_group_new(nm_folder_get_name(folder));
+--- /src/protocols/novell/novell.c 22 Apr 2004 01:53:15 -0000 1.9
++++ /src/protocols/novell/novell.c 23 Apr 2004 09:56:52 -0000
+@@ -2062,6 +2062,7 @@ novell_rename_group(GaimConnection * gc,
+ {
+ NMERR_T rc = NM_OK;
+ NMUser *user;
++ NMFolder *folder;
+
+ if (gc == NULL || old_name == NULL || new_name == NULL || tobemoved == NULL) {
+ return;
+@@ -2078,7 +2079,7 @@ novell_rename_group(GaimConnection * gc,
+ return;
+ }
+
+- NMFolder *folder = nm_find_folder(user, old_name);
++ folder = nm_find_folder(user, old_name);
+
+ if (folder) {
+ rc = nm_send_rename_folder(user, folder, new_name,
+--- /src/gtkrequest.c Sun Apr 18 09:22:41 2004
++++ /src/gtkrequest.c Fri Apr 23 13:42:07 2004
+@@ -261,6 +261,7 @@
+ GtkWidget *entry;
+ GtkWidget *img;
+ char *label_text;
++ GtkWidget *toolbar;
+
+ data = g_new0(GaimGtkRequestData, 1);
+ data->type = GAIM_REQUEST_INPUT;
+@@ -338,7 +339,6 @@
+ gtk_widget_set_size_request(sw, 320, 130);
+
+ /* Toolbar */
+- GtkWidget *toolbar;
+ toolbar = gtk_imhtmltoolbar_new();
+ gtk_box_pack_start(GTK_BOX(vbox), toolbar, FALSE, FALSE, 0);
+
+--- /src/gtkimhtml.c Thu Apr 22 19:24:05 2004
++++ /src/gtkimhtml.c Fri Apr 23 13:40:12 2004
+@@ -539,13 +539,14 @@
+ #if GTK_CHECK_VERSION(2,2,0)
+ static void gtk_imhtml_clipboard_get(GtkClipboard *clipboard, GtkSelectionData *selection_data, guint info, GtkIMHtml *imhtml) {
+ char *text;
++ gboolean primary ;
+ GtkTextIter start, end;
+ GtkTextMark *sel = gtk_text_buffer_get_selection_bound(imhtml->text_buffer);
+ GtkTextMark *ins = gtk_text_buffer_get_insert(imhtml->text_buffer);
+
+ gtk_text_buffer_get_iter_at_mark(imhtml->text_buffer, &start, sel);
+ gtk_text_buffer_get_iter_at_mark(imhtml->text_buffer, &end, ins);
+- gboolean primary = gtk_widget_get_clipboard(GTK_WIDGET(imhtml), GDK_SELECTION_PRIMARY) == clipboard;
++ primary= gtk_widget_get_clipboard(GTK_WIDGET(imhtml), GDK_SELECTION_PRIMARY) == clipboard;
+
+ if (info == TARGET_HTML) {
+ int len;
diff --git a/net-im/gaim/gaim-0.77.ebuild b/net-im/gaim/gaim-0.77.ebuild
new file mode 100644
index 000000000000..ee1a9a0d50e0
--- /dev/null
+++ b/net-im/gaim/gaim-0.77.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.77.ebuild,v 1.1 2004/04/23 12:24:11 rizzo Exp $
+
+inherit flag-o-matic eutils gcc
+use debug && inherit debug
+
+IUSE="nls perl spell nas debug crypt cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~mips ~hppa"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.8.2 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ || ( dev-libs/nss net-www/mozilla )"
+PDEPEND="crypt? ( >=net-im/gaim-encryption-2.24-r1 )"
+
+pkg_setup() {
+ ewarn
+ ewarn "If you are merging ${P} from an earlier version, you will need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ # Double beep here.
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gaim-0.77-c99.patch
+ use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
+}
+
+src_compile() {
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ has_version dev-libs/nss && {
+ # Only need to specify this if no pkgconfig from mozilla
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+ }
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+
+ # Copy header files for gaim plugin use
+ dodir /usr/include/gaim/src
+ cp config.h ${D}/usr/include/gaim/
+ cd ${S}/src
+ tar cf - *.h | (cd ${D}/usr/include/gaim/src ; tar xvf -)
+ assert "Failed to install header files to /usr/include/gaim"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are merging ${P} from an earlier version, you will need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ # Double beep here.
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+}