summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-29 02:33:27 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-29 02:33:27 +0000
commit6dcaf61c911d88ffe2213b8e25403aa3ea2a1f11 (patch)
treed679238e5377257cef67e6f357efd888d14bc839 /net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild
parentold (diff)
downloadhistorical-6dcaf61c911d88ffe2213b8e25403aa3ea2a1f11.tar.gz
historical-6dcaf61c911d88ffe2213b8e25403aa3ea2a1f11.tar.bz2
historical-6dcaf61c911d88ffe2213b8e25403aa3ea2a1f11.zip
Fixup manpage install and cleanup ebuild.
Package-Manager: portage-2.2_pre5 RepoMan-Options: --force
Diffstat (limited to 'net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild')
-rw-r--r--net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild b/net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild
new file mode 100644
index 000000000000..c99504a1374f
--- /dev/null
+++ b/net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r6.ebuild,v 1.1 2008/03/29 02:33:27 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="the tftp server included in netkit"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-tftp-0.17.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="!virtual/tftp
+ virtual/inetd"
+PROVIDE="virtual/tftp"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Change default man directory
+ sed -i \
+ -e 's:MANDIR="$PREFIX/man":MANDIR="$PREFIX/share/man":' \
+ -e 's:^LDFLAGS=::' \
+ configure
+
+ # don't prestrip binaries
+ find . -name Makefile -print0 | xargs -0 sed -i -e 's:install -s:install:'
+
+ # Solve QA warning by including string.h
+ epatch "${FILESDIR}"/memset.patch
+ epatch "${FILESDIR}"/${P}-tftp-connect-segfault.patch
+ epatch "${FILESDIR}"/${P}-tftp-manpage-typo.patch
+ epatch "${FILESDIR}"/${P}-tftp-fix-put-zero-size.diff
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --installroot="${D}" \
+ --with-c-compiler="$(tc-getCC)" \
+ || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/share/man/man{1,8}
+ emake install || die
+ rm -f "${D}"/usr/share/man/man8/tftpd.8
+ insinto /etc/xinetd.d
+ doins "${FILESDIR}"/{tftp-dgram,tftp-stream}
+ dodoc BUGS ChangeLog README
+}