summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-10-05 17:27:33 +0000
committerRoy Marples <uberlord@gentoo.org>2005-10-05 17:27:33 +0000
commit766ad858ad77bb2a51b0dba6c8ae7a41efbb884b (patch)
tree574618772c35895c03e3e4f62e1b6e5960334f7e /net-ftp/ftpbase/ftpbase-0.00.ebuild
parentalpha-sources no longer exist wrt bug #107940 (diff)
downloadhistorical-766ad858ad77bb2a51b0dba6c8ae7a41efbb884b.tar.gz
historical-766ad858ad77bb2a51b0dba6c8ae7a41efbb884b.tar.bz2
historical-766ad858ad77bb2a51b0dba6c8ae7a41efbb884b.zip
Use "egethome ftp" instead of greping and cuting /etc/passwd.
This allows us to work on other platforms with a minimum of fuss. Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-ftp/ftpbase/ftpbase-0.00.ebuild')
-rw-r--r--net-ftp/ftpbase/ftpbase-0.00.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-ftp/ftpbase/ftpbase-0.00.ebuild b/net-ftp/ftpbase/ftpbase-0.00.ebuild
index 512dbb40987e..0390ce7b59b1 100644
--- a/net-ftp/ftpbase/ftpbase-0.00.ebuild
+++ b/net-ftp/ftpbase/ftpbase-0.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.11 2005/10/02 23:01:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.12 2005/10/05 17:27:33 uberlord Exp $
inherit eutils pam
@@ -83,11 +83,11 @@ pkg_postinst() {
# Install manually using install -d until bug #9849 is solved.
# This means that the home directory will not be removed when we uninstall
# if it's empty.
- local homedir="${ROOT}$( egetent passwd ftp | cut -d: -f6 )"
+ local homedir=$( egethome ftp )
if [[ ! -d ${homedir} ]]; then
einfo "Creating home directory for ftp user"
einfo " ${homedir}"
install -d "${homedir}" \
- || ewarn " can't create ${homedir}"
+ || ewarn " can't create ${homedir}"
fi
}