summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-02-18 05:45:42 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-02-18 05:45:42 +0000
commitd87520d13551e9e5ff9a2c6aac39c7fbb75b1616 (patch)
treef6ad35c2a6ee0efdf8762c40d526cc8c51c2bf0b /net-fs/openafs
parentadded Jon Nials new ebuild and patch. fixes #37961 (diff)
downloadhistorical-d87520d13551e9e5ff9a2c6aac39c7fbb75b1616.tar.gz
historical-d87520d13551e9e5ff9a2c6aac39c7fbb75b1616.tar.bz2
historical-d87520d13551e9e5ff9a2c6aac39c7fbb75b1616.zip
added Jon Nials new ebuild and patch. fixes #37961
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/Manifest8
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.111
-rw-r--r--net-fs/openafs/files/openafs-pinstall-execve-env.patch58
-rw-r--r--net-fs/openafs/openafs-1.2.10-r1.ebuild4
-rw-r--r--net-fs/openafs/openafs-1.2.10.ebuild4
-rw-r--r--net-fs/openafs/openafs-1.2.11.ebuild129
6 files changed, 196 insertions, 8 deletions
diff --git a/net-fs/openafs/Manifest b/net-fs/openafs/Manifest
index dfcbdf8d64aa..4a05a7a190e9 100644
--- a/net-fs/openafs/Manifest
+++ b/net-fs/openafs/Manifest
@@ -1,9 +1,9 @@
-MD5 fd52512c183bee3b0f0abb0a2f7574da openafs-1.2.11.ebuild 3267
+MD5 13b6c4e9e6c778a1079cb980681b94cc openafs-1.2.11.ebuild 3369
MD5 7a7b6d938953c3686f2929498e9accc0 openafs-1.2.10-r2.ebuild 3381
-MD5 cd27be8a0ad61a4008a7ca13a261a845 openafs-1.2.10.ebuild 2247
-MD5 a7fadba3ef7b49dc7f4f497ff3d60075 ChangeLog 5725
+MD5 af25a4667ed3c1c476fc515c8734af1c openafs-1.2.10.ebuild 2247
+MD5 902c3ee1422cb7c662a856dfca450d58 ChangeLog 5926
MD5 1d3c436cc14252035bf2d97228cd3f58 metadata.xml 224
-MD5 496031fdde3cbb725b1d32213cd2586e openafs-1.2.10-r1.ebuild 2437
+MD5 18ae5558a54d73dc8d39bfd93e09e524 openafs-1.2.10-r1.ebuild 2437
MD5 4584cc6910401787e1ebd81cfa06f060 files/CellServDB 41
MD5 e8488032f070544719cba9c7dbaf8108 files/digest-openafs-1.2.10-r1 73
MD5 e8488032f070544719cba9c7dbaf8108 files/digest-openafs-1.2.10-r2 73
diff --git a/net-fs/openafs/files/digest-openafs-1.2.11 b/net-fs/openafs/files/digest-openafs-1.2.11
new file mode 100644
index 000000000000..abbbbc0b349c
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.11
@@ -0,0 +1 @@
+MD5 7be9e2814e063317cdab00da9a32739d openafs-1.2.11-src.tar.bz2 10353304
diff --git a/net-fs/openafs/files/openafs-pinstall-execve-env.patch b/net-fs/openafs/files/openafs-pinstall-execve-env.patch
new file mode 100644
index 000000000000..4fd9c4e61cc3
--- /dev/null
+++ b/net-fs/openafs/files/openafs-pinstall-execve-env.patch
@@ -0,0 +1,58 @@
+--- openafs/src/pinstall/install.c 2003-07-25 04:40:16.000000000 +0000
++++ openafs/src/pinstall/install.c 2003-11-17 21:47:15.000000000 +0000
+@@ -172,6 +172,9 @@
+ char *iname, *oname; {
+ int pid;
+ pid_t status;
++ static char *env[] = {
++ 0,
++ };
+ static char *strip[] = {
+ "strip", 0, 0,
+ };
+@@ -190,7 +193,7 @@
+ case 0: /* child */
+ copy[1] = iname;
+ copy[2] = oname;
+- execve("/bin/cp", copy, (char **)0);
++ execve("/bin/cp", copy, env);
+ perror("/bin/cp");
+ exit(1);
+
+@@ -236,7 +239,7 @@
+ #else
+ #define STRIP_BIN "/bin/strip"
+ #endif
+- execve(STRIP_BIN, strip, (char **)0);
++ execve(STRIP_BIN, strip, env);
+ perror(STRIP_BIN);
+ exit(1);
+
+@@ -281,6 +284,9 @@
+ quickStrip (iname, oname, ignored, copy_only)
+ char *iname, *oname; {
+ int pid, status;
++ static char *env[] = {
++ 0,
++ };
+ static char *strip[] = {
+ "strip", 0, 0,
+ };
+@@ -299,7 +305,7 @@
+ case 0: /* child */
+ copy[1] = iname;
+ copy[2] = oname;
+- execve("/bin/cp", copy, 0);
++ execve("/bin/cp", copy, env);
+ perror("/bin/cp");
+ exit(1);
+
+@@ -337,7 +343,7 @@
+
+ case 0: /* child */
+ strip[1] = oname;
+- execve("/bin/strip", strip, 0);
++ execve("/bin/strip", strip, env);
+ perror("/bin/strip");
+ exit(1);
+
diff --git a/net-fs/openafs/openafs-1.2.10-r1.ebuild b/net-fs/openafs/openafs-1.2.10-r1.ebuild
index 8f004017fcbf..c7c258a53119 100644
--- a/net-fs/openafs/openafs-1.2.10-r1.ebuild
+++ b/net-fs/openafs/openafs-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.10-r1.ebuild,v 1.7 2003/11/26 01:12:23 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.10-r1.ebuild,v 1.8 2004/02/18 05:45:35 rphillips Exp $
inherit check-kernel fixheadtails
diff --git a/net-fs/openafs/openafs-1.2.10.ebuild b/net-fs/openafs/openafs-1.2.10.ebuild
index a576dc177979..03238d1e6e70 100644
--- a/net-fs/openafs/openafs-1.2.10.ebuild
+++ b/net-fs/openafs/openafs-1.2.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.10.ebuild,v 1.6 2003/11/21 18:25:30 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.10.ebuild,v 1.7 2004/02/18 05:45:35 rphillips Exp $
inherit check-kernel
diff --git a/net-fs/openafs/openafs-1.2.11.ebuild b/net-fs/openafs/openafs-1.2.11.ebuild
new file mode 100644
index 000000000000..c6a805a2a579
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.11.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.11.ebuild,v 1.1 2004/02/18 05:45:35 rphillips Exp $
+
+inherit check-kernel fixheadtails flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 scalable distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+SRC_URI="http://openafs.org/dl/openafs/${PV}/${P}-src.tar.bz2"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="~x86 ~alpha ~ia64"
+
+DEPEND="virtual/linux-sources
+ >=sys-apps/portage-2.0.47-r10
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75
+ >=sys-apps/gawk-3.1.1"
+
+pkg_setup() {
+ if is_2_5_kernel || is_2_6_kernel
+ then
+ die "OpenAFS does not yet support 2.5 and 2.6 kernels"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ ht_fix_file "acinclude.m4"
+ ht_fix_file "config.guess"
+ ht_fix_file "src/afsd/afs.rc.linux"
+ ht_fix_file "aclocal.m4"
+ ht_fix_file "configure"
+ ht_fix_file "configure-libafs"
+ epatch ${FILESDIR}/openafs-pinstall-execve-env.patch
+}
+
+src_compile() {
+ # The CC/MT_CC setting is required for link on alpha, and
+ # recommended for link on x86 and other arches (even those that
+ # don't technically require it).
+ # http://marc.theaimsgroup.com/?l=gentoo-dev&m=107112691504786&w=2
+ #
+ # It's possible that CFLAGS could be added to MT_CC as well, but
+ # I'm not experimenting here, just making it work on multiple
+ # arches... (12 Jan 2004 agriffis)
+ econf --enable-transarc-paths || die econf
+ make CC="${CC}" MT_CC="${CC}" || die make
+}
+
+src_install () {
+ local sys_name=$(sed -n 's/^SYS_NAME=//p' Makefile) || die sys_name
+
+ make dest || die dest
+
+ # Client
+ cd ${S}/${sys_name}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ # Can't make this in src_install with keepdir because there might
+ # be mounted afs filesystems at the time that this package is
+ # installed/updated. Can't test with mount because this might not
+ # be the host where the package will be installed. The best way
+ # to do this is put it in pkg_* functions. (12 Jan 2004 agriffis)
+ #mount -t afs | awk '{ exit $3 == "/afs" }' && keepdir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${sys_name}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${sys_name}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+
+ dodir /etc/env.d
+ echo 'CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws"' \
+ >> ${D}/etc/env.d/01${PN}
+ echo 'PATH=/usr/afsws/bin:/etc/afs/afsws' \
+ >> ${D}/etc/env.d/01${PN}
+ echo 'ROOTPATH=/usr/afsws/bin:/etc/afs/afsws:/usr/afs/bin' \
+ >> ${D}/etc/env.d/01${PN}
+}
+
+pkg_postinst () {
+ # See note in src_install regarding this
+ mkdir /afs 2>/dev/null
+
+ einfo
+ einfo "UPDATE CellServDB and ThisCell to your needs !!"
+ einfo "FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ einfo "PAGE >45 TO DO INITIAL SERVER SETUP"
+ einfo
+}
+
+pkg_preun () {
+ # See note in src_install regarding this
+ rmdir /afs 2>/dev/null
+}