summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-05-28 20:00:02 +0000
committerPeter Volkov <pva@gentoo.org>2010-05-28 20:00:02 +0000
commit9c2ab24bf87b21b038bc2e622d69716dab4b1b8d (patch)
tree056e576f176ce4236a46dc0981316fd95e9da880 /net-fs/autofs/autofs-5.0.4-r5.ebuild
parentRemove old versions (diff)
downloadhistorical-9c2ab24bf87b21b038bc2e622d69716dab4b1b8d.tar.gz
historical-9c2ab24bf87b21b038bc2e622d69716dab4b1b8d.tar.bz2
historical-9c2ab24bf87b21b038bc2e622d69716dab4b1b8d.zip
Added missed dependenices, disabled automagic hesiod, bug 292147, thank Dustin Polke for this job. Dustin stepped in as co-maintainer (/me proxy).
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'net-fs/autofs/autofs-5.0.4-r5.ebuild')
-rw-r--r--net-fs/autofs/autofs-5.0.4-r5.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/net-fs/autofs/autofs-5.0.4-r5.ebuild b/net-fs/autofs/autofs-5.0.4-r5.ebuild
index f9609057684d..b5375398ff10 100644
--- a/net-fs/autofs/autofs-5.0.4-r5.ebuild
+++ b/net-fs/autofs/autofs-5.0.4-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.4-r5.ebuild,v 1.2 2009/09/23 18:35:30 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.4-r5.ebuild,v 1.3 2010/05/28 20:00:02 pva Exp $
inherit eutils multilib autotools
@@ -74,8 +74,11 @@ SRC_URI="${SRC_URI_BASE}/${P}.tar.bz2"
for i in ${PATCH_LIST} ; do
SRC_URI="${SRC_URI} ${SRC_URI_BASE}/${i}"
done ;
-DEPEND="ldap? ( >=net-nds/openldap-2.0 )
- sasl? ( virtual/krb5 )"
+DEPEND="ldap? ( >=net-nds/openldap-2.0
+ sasl? ( dev-libs/cyrus-sasl
+ virtual/krb5
+ dev-libs/libxml2 )
+ )"
# currently, sasl code assumes the presence of kerberosV
RDEPEND="${DEPEND}"
SLOT="0"
@@ -88,8 +91,6 @@ src_unpack() {
EPATCH_OPTS="-p1 -d ${S}" epatch "${DISTDIR}"/${i}
done
- cd "${S}"
-
# fixes bug #210762
epatch "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
@@ -117,6 +118,7 @@ src_compile() {
econf \
$(use_with ldap openldap) \
$(use_with sasl) \
+ --without-hesiod \
--enable-ignore-busy \
|| die "configure failed"