summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-07-04 11:42:58 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-07-04 11:42:58 +0000
commitaf6b33327ce84e5daad002062b3613efdcc22ad0 (patch)
tree264f6704efb71b871d556b19e5525bfc6a09b315 /net-firewall
parentAdded to ~ppc (diff)
downloadhistorical-af6b33327ce84e5daad002062b3613efdcc22ad0.tar.gz
historical-af6b33327ce84e5daad002062b3613efdcc22ad0.tar.bz2
historical-af6b33327ce84e5daad002062b3613efdcc22ad0.zip
More bugs fixed.
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog9
-rw-r--r--net-firewall/iptables/Manifest6
-rw-r--r--net-firewall/iptables/iptables-1.2.11-r2.ebuild15
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r4.ebuild5
4 files changed, 23 insertions, 12 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 63ea76dc5116..88b9fa79f5c8 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.36 2004/07/03 17:50:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.37 2004/07/04 11:42:58 aliz Exp $
+
+ 04 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.11-r2.ebuild:
+ + Fix installation path, initscript and config script. Closing #55978.
+ + Fix dependencies. Closing #55605
+
+ 04 Jul 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r4.ebuild:
+ + Fix dependencies. Closing #55605
03 Jul 2004; Seemant Kulleen <seemant@gentoo.org> iptables-1.2.11-r2.ebuild:
sed statement fix, thanks to x1bncwn in #gentoo
diff --git a/net-firewall/iptables/Manifest b/net-firewall/iptables/Manifest
index ac8c0737e780..e9d902fdf6a7 100644
--- a/net-firewall/iptables/Manifest
+++ b/net-firewall/iptables/Manifest
@@ -1,9 +1,9 @@
MD5 3dc5f4c2b8833a4b3aa2fe9c426352fd iptables-1.2.7a-r3.ebuild 1972
-MD5 fa0872850adb341575de6f101a2d2d69 iptables-1.2.9-r4.ebuild 5383
+MD5 9747ed6f49085669b25a0a649c58fd9a iptables-1.2.9-r4.ebuild 5419
MD5 662217b275d0637dec337290c30528db iptables-1.2.9.ebuild 2797
MD5 68481d5e196c5e00c0512688625f0410 iptables-1.2.9-r1.ebuild 3516
-MD5 81d94a7c3fe41fa0c5c7a526ee1f7a8c iptables-1.2.11-r2.ebuild 5241
-MD5 0b1d3591ee67d7c09aee262dc55ba95d ChangeLog 12515
+MD5 215b2ae8729712f4be9fd3cb9442685a iptables-1.2.11-r2.ebuild 5300
+MD5 6c4f8eb542cf382d3aa75c4504a3be79 ChangeLog 12810
MD5 37236013e0d26d43c6bff35a8a48e8ec metadata.xml 220
MD5 f876be872ec78bc824f2503059338d8d files/iptables.confd 382
MD5 11b6d4adeda9db7a96bc9c1238320fb5 files/ip6tables.init 2107
diff --git a/net-firewall/iptables/iptables-1.2.11-r2.ebuild b/net-firewall/iptables/iptables-1.2.11-r2.ebuild
index 61f977871543..d5d5e383970a 100644
--- a/net-firewall/iptables/iptables-1.2.11-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.2.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.11-r2.ebuild,v 1.2 2004/07/03 17:50:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.11-r2.ebuild,v 1.3 2004/07/04 11:42:58 aliz Exp $
inherit eutils flag-o-matic
@@ -14,7 +14,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
IUSE="ipv6 static extensions"
-DEPEND="virtual/linux-sources"
+DEPEND="virtual/os-headers
+ extensions? ( virtual/linux-sources )"
pkg_setup() {
if use extensions; then
@@ -100,6 +101,7 @@ src_compile() {
src_install() {
if use extensions; then
make DESTDIR=${D} ${myconf} \
+ PREFIX= \
LIBDIR=/lib \
MANDIR=/usr/share/man \
INCDIR=/usr/include \
@@ -107,6 +109,7 @@ src_install() {
install || die "Please check http://cvs.iptables.org/patch-o-matic-ng/updates/ if your kernel needs to be patched for iptables"
make DESTDIR=${D} ${myconf} \
+ PREFIX= \
LIBDIR=/usr/lib \
MANDIR=/usr/share/man \
INCDIR=/usr/include \
@@ -131,16 +134,16 @@ src_install() {
dodoc COPYING
dodir /var/lib/iptables ; keepdir /var/lib/iptables
exeinto /etc/init.d
- newexe ${FILESDIR}/${PN}-${PV}-r1.init iptables
+ newexe ${FILESDIR}/${PN}-1.2.9-r1.init iptables
insinto /etc/conf.d
- newins ${FILESDIR}/${PN}-${PV}-r1.confd iptables
+ newins ${FILESDIR}/${PN}-1.2.9-r1.confd iptables
if use ipv6; then
dodir /var/lib/ip6tables ; keepdir /var/lib/ip6tables
exeinto /etc/init.d
- newexe ${FILESDIR}/${PN/iptables/ip6tables}-${PV}-r1.init ip6tables
+ newexe ${FILESDIR}/${PN/iptables/ip6tables}-1.2.9-r1.init ip6tables
insinto /etc/conf.d
- newins ${FILESDIR}/${PN/iptables/ip6tables}-${PV}-r1.confd ip6tables
+ newins ${FILESDIR}/${PN/iptables/ip6tables}-1.2.9-r1.confd ip6tables
fi
}
diff --git a/net-firewall/iptables/iptables-1.2.9-r4.ebuild b/net-firewall/iptables/iptables-1.2.9-r4.ebuild
index bcaffe0874b9..f01d5fca8d57 100644
--- a/net-firewall/iptables/iptables-1.2.9-r4.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r4.ebuild,v 1.1 2004/07/03 15:36:32 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r4.ebuild,v 1.2 2004/07/04 11:42:58 aliz Exp $
inherit eutils flag-o-matic
@@ -12,7 +12,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc ~mips alpha arm hppa amd64 ia64"
IUSE="ipv6 static extensions"
-DEPEND="virtual/linux-sources"
+DEPEND="virtual/os-headers
+ extensions? ( virtual/linux-sources )"
pkg_setup() {
if use extensions; then