summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2011-06-19 14:56:54 +0000
committerConstanze Hausner <constanze@gentoo.org>2011-06-19 14:56:54 +0000
commit877ef915b683e8ee0d24171c688cd711628cfe5f (patch)
tree6c63d72ddac2ec94edaf5a8dd60ccf886125cc59 /net-firewall/shorewall
parentVersion bump with patch for install.sh; EAPI bump to EAPI4; General cleanup (diff)
downloadhistorical-877ef915b683e8ee0d24171c688cd711628cfe5f.tar.gz
historical-877ef915b683e8ee0d24171c688cd711628cfe5f.tar.bz2
historical-877ef915b683e8ee0d24171c688cd711628cfe5f.zip
Version bump; EAPI bump to EAPI4; General cleanup
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/ChangeLog8
-rw-r--r--net-firewall/shorewall/shorewall-4.4.20.3.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index db7c906d96ee..4ed281838410 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.187 2011/05/21 15:05:06 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.188 2011/06/19 14:52:57 constanze Exp $
+
+*shorewall-4.4.20.3 (19 Jun 2011)
+
+ 19 Jun 2011; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-4.4.20.3.ebuild:
+ Version bump; EAPI bump to EAPI4; General cleanup
*shorewall-4.4.19.4 (21 May 2011)
diff --git a/net-firewall/shorewall/shorewall-4.4.20.3.ebuild b/net-firewall/shorewall/shorewall-4.4.20.3.ebuild
new file mode 100644
index 000000000000..7ea1f387bd9c
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.4.20.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.4.20.3.ebuild,v 1.1 2011/06/19 14:52:57 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}"
+MY_P_DOCS="${P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ !net-firewall/shorewall-common
+ !net-firewall/shorewall-shell
+ !net-firewall/shorewall-perl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+}
+
+pkg_postinst() {
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+}