summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-29 00:55:03 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-29 00:55:03 +0000
commitd19f63797573f43ce392be56bf42e6ac3217c32e (patch)
tree1248b0606c23a939a46398eadcce97d8f1223c92 /net-dns/pdnsd
parentnew category: net-dns (diff)
downloadhistorical-d19f63797573f43ce392be56bf42e6ac3217c32e.tar.gz
historical-d19f63797573f43ce392be56bf42e6ac3217c32e.tar.bz2
historical-d19f63797573f43ce392be56bf42e6ac3217c32e.zip
new category: net-dns. initial import
Diffstat (limited to 'net-dns/pdnsd')
-rw-r--r--net-dns/pdnsd/ChangeLog13
-rw-r--r--net-dns/pdnsd/files/digest-pdnsd-1.1.6-r71
-rw-r--r--net-dns/pdnsd/files/pdnsd.rc630
-rw-r--r--net-dns/pdnsd/pdnsd-1.1.6-r7.ebuild37
4 files changed, 81 insertions, 0 deletions
diff --git a/net-dns/pdnsd/ChangeLog b/net-dns/pdnsd/ChangeLog
new file mode 100644
index 000000000000..b38b5f35c65c
--- /dev/null
+++ b/net-dns/pdnsd/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-misc/pdnsd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/ChangeLog,v 1.1 2002/06/29 00:55:03 bangert Exp $
+
+*pdnsd-1.1.6-r7 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-dns/pdnsd/files/digest-pdnsd-1.1.6-r7 b/net-dns/pdnsd/files/digest-pdnsd-1.1.6-r7
new file mode 100644
index 000000000000..84bd49ec361a
--- /dev/null
+++ b/net-dns/pdnsd/files/digest-pdnsd-1.1.6-r7
@@ -0,0 +1 @@
+MD5 24d7cede5de8fcf2709e82eeaa780352 pdnsd-1.1.6.tar.bz2 222766
diff --git a/net-dns/pdnsd/files/pdnsd.rc6 b/net-dns/pdnsd/files/pdnsd.rc6
new file mode 100644
index 000000000000..51c34ea1e687
--- /dev/null
+++ b/net-dns/pdnsd/files/pdnsd.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/files/pdnsd.rc6,v 1.1 2002/06/29 00:55:03 bangert Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/pdnsd/pdnsd.conf ] ; then
+ eerror "You need an /etc/pdnsd/pdnsd.conf file first"
+ eerror "There is a sample in /usr/share/doc/pdnsd"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting pdnsd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/pdnsd \
+ -- -d -p /var/run/pdnsd.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pdnsd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/pdnsd.pid
+ eend $?
+}
diff --git a/net-dns/pdnsd/pdnsd-1.1.6-r7.ebuild b/net-dns/pdnsd/pdnsd-1.1.6-r7.ebuild
new file mode 100644
index 000000000000..7d11b70a7ed2
--- /dev/null
+++ b/net-dns/pdnsd/pdnsd-1.1.6-r7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry A! <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdnsd/pdnsd-1.1.6-r7.ebuild,v 1.1 2002/06/29 00:55:03 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Proxy DNS server with permanent caching"
+SRC_URI="http://home.t-online.de/home/Moestl/${P}.tar.bz2"
+HOMEPAGE="http://home.t-online.de/home/Moestl/"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/pdnsd \
+ --with-cachedir=/var/lib/pdnsd \
+ --host=${CHOST} || die "bad configure"
+
+ emake all || die "compile problem"
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING* ChangeLog* NEWS README THANKS TODO
+ docinto contrib ; dodoc contrib/{README,dhcp2pdnsd,pdnsd_dhcp.pl}
+ docinto html ; dodoc doc/html/*
+ docinto txt ; dodoc doc/txt/*
+ newdoc doc/pdnsd.conf pdnsd.conf.sample
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pdnsd.rc6 pdnsd
+}