summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-07-20 16:19:40 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-07-20 16:19:40 +0000
commit4846a0ddad9e6fddb05ad7be37fcde7d7b2a2602 (patch)
tree1bb39e9b89a2e70072af773a82a5395c4292fcb5 /net-dialup
parentInitial ebuild. (diff)
downloadhistorical-4846a0ddad9e6fddb05ad7be37fcde7d7b2a2602.tar.gz
historical-4846a0ddad9e6fddb05ad7be37fcde7d7b2a2602.tar.bz2
historical-4846a0ddad9e6fddb05ad7be37fcde7d7b2a2602.zip
Updated to latest from upstream.
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/gammu/Manifest2
-rw-r--r--net-dialup/gammu/files/digest-gammu-0.97.01
-rw-r--r--net-dialup/gammu/gammu-0.97.0.ebuild50
3 files changed, 53 insertions, 0 deletions
diff --git a/net-dialup/gammu/Manifest b/net-dialup/gammu/Manifest
index 2df76cce2e9c..c1093a1ad7bc 100644
--- a/net-dialup/gammu/Manifest
+++ b/net-dialup/gammu/Manifest
@@ -1,3 +1,4 @@
+MD5 308d11cd61e9a4c5399c69caaf8cc441 gammu-0.97.0.ebuild 1371
MD5 39f9d57dcf1f459afc41f126cb9de139 gammu-0.95.0.ebuild 1372
MD5 5e08191fec4d79815f26f3ba7ee473a7 gammu-0.94.4.ebuild 1372
MD5 9be47d25c98d2cfd62f3515db28391e1 gammu-0.96.0.ebuild 1373
@@ -6,5 +7,6 @@ MD5 87844c6e9a700c2b04cceac0b33a1a79 metadata.xml 225
MD5 a4d07a2216ae4484fa916a009aeb1e05 files/digest-gammu-0.94.4 64
MD5 5e7b1e71a6d9ce5a97ff8fae6e9b2704 files/digest-gammu-0.95.0 64
MD5 e975f31e8196ac8627b2807f40f2976e files/digest-gammu-0.96.0 64
+MD5 14917071654d14787fa58963153565d4 files/digest-gammu-0.97.0 64
MD5 58b1c83d7bc4fde7a68ff5d837e9153e files/gammu-0.95.0-LastCalendar.patch 576
MD5 1e26cc450b853c7c166bc4feebe4d62b files/gammu-0.94.4-LastCalendar.patch 581
diff --git a/net-dialup/gammu/files/digest-gammu-0.97.0 b/net-dialup/gammu/files/digest-gammu-0.97.0
new file mode 100644
index 000000000000..ce883a8e5805
--- /dev/null
+++ b/net-dialup/gammu/files/digest-gammu-0.97.0
@@ -0,0 +1 @@
+MD5 2b713522f50038d29887e027c578a30d gammu-0.97.0.tar.gz 758939
diff --git a/net-dialup/gammu/gammu-0.97.0.ebuild b/net-dialup/gammu/gammu-0.97.0.ebuild
new file mode 100644
index 000000000000..374d293bee1f
--- /dev/null
+++ b/net-dialup/gammu/gammu-0.97.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gammu/gammu-0.97.0.ebuild,v 1.1 2004/07/20 16:19:40 st_lim Exp $
+
+inherit eutils
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+SRC_URI="http://www.mwiacek.com/zips/gsm/gammu/older/${P}.tar.gz"
+HOMEPAGE="http://www.mwiacek.com/gsm/gammu/gammu.html"
+
+IUSE="bluetooth irda mysql nls ssl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="irda? ( virtual/os-headers )
+ mysql? ( dev-db/mysql )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ bluetooth? ( net-wireless/bluez-libs )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ #epatch ${FILESDIR}/${P}-LastCalendar.patch
+}
+
+src_compile() {
+ local myconf
+ use bluetooth && myconf="${myconf} --with-bluedir=/usr/lib"
+ use irda || myconf="${myconf} --disable-irdaat --disable-irdaphonet"
+ econf \
+ `use_enable nls` \
+ --prefix=/usr \
+ --enable-cb \
+ --enable-7110incoming \
+ --enable-6210calendar \
+ ${myconf} || die "configure failed"
+
+ sed -e 's:-lz -pthread:-lz -lpthread -lssl:g' \
+ -i ${S}/cfg/Makefile.cfg
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} installlib || die "install failed"
+ doman docs/docs/english/gammu.1
+ mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${P}
+}