summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2005-05-10 05:32:43 +0000
committerEldad Zack <eldad@gentoo.org>2005-05-10 05:32:43 +0000
commitfff40920d49c75985e76813595b7de88dab73ef6 (patch)
tree7c5f8dbb1ed42304d4ce633c6bef590f319a8a59 /net-analyzer
parentinitial import (diff)
downloadhistorical-fff40920d49c75985e76813595b7de88dab73ef6.tar.gz
historical-fff40920d49c75985e76813595b7de88dab73ef6.tar.bz2
historical-fff40920d49c75985e76813595b7de88dab73ef6.zip
Fixed ACCESS VIOLATION that occurs if there is no /var/lib/ntop.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ntop/ChangeLog5
-rw-r--r--net-analyzer/ntop/Manifest16
-rw-r--r--net-analyzer/ntop/ntop-3.1.ebuild3
3 files changed, 14 insertions, 10 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 8caa4307936b..81173994d725 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ntop
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.35 2005/02/19 12:00:58 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.36 2005/05/10 05:32:43 eldad Exp $
+
+ 09 May 2005; Eldad Zack <eldad@gentoo.org> ntop-3.1.ebuild:
+ Fixed ACCESS VIOLATION that occurs if there is no /var/lib/ntop.
19 Feb 2005; Daniel Black <dragonheart@gentoo.org> ntop-3.1.ebuild:
Quoted NTOP_OPTS in /etc/conf.d/ntop to fix bug #80663. Thanks to\ Alan McNeil
diff --git a/net-analyzer/ntop/Manifest b/net-analyzer/ntop/Manifest
index 8d44a09983a0..6405def5a030 100644
--- a/net-analyzer/ntop/Manifest
+++ b/net-analyzer/ntop/Manifest
@@ -1,19 +1,19 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 6387a827ba513cc9fd9749bc3f6298a0 ChangeLog 4422
-MD5 846e7479e3e9df4363f2721b7fb47320 metadata.xml 233
+MD5 b8e56d2773a4f1242363d7d210c15980 ntop-3.1.ebuild 2427
MD5 ebf97d76921e175f2af48c0811a84cec ntop-3.0.ebuild 1604
-MD5 e359b795c421393d502bfdb71932595a ntop-3.1.ebuild 2344
+MD5 04ce4af93742d78e59986b9e8e6d4315 ChangeLog 4546
+MD5 846e7479e3e9df4363f2721b7fb47320 metadata.xml 233
MD5 35c576fac5bd8cbf0da850ccc00dd924 files/digest-ntop-3.0 58
MD5 bb970d07a76d2b939ec08c2796519021 files/digest-ntop-3.1 58
-MD5 d1e896708a98eaca02f55c44ae517768 files/globals-core.c.diff 536
MD5 a9cad5851ac81cbd8589f60287f3e497 files/ntop-confd 131
+MD5 d1e896708a98eaca02f55c44ae517768 files/globals-core.c.diff 536
MD5 9e6b1e20779d7fb6699c956adf6b8b05 files/ntop-init 294
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFCFyqAmdTrptrqvGERAr50AJ9hR1GsCjAqS0kJ8iII24gbzjnj9wCgkZxG
-kF+Y+NPAQjz2kqJuihGXU6M=
-=sG8z
+iD8DBQFCgEeQT+MN7JbqCpMRAuObAJ4siE/QbawJLnyraF+QDzhvyqaDwQCfZzQZ
+zWiR43tLQHuz/LQbwYedxqY=
+=TEEH
-----END PGP SIGNATURE-----
diff --git a/net-analyzer/ntop/ntop-3.1.ebuild b/net-analyzer/ntop/ntop-3.1.ebuild
index ddc21d0d1775..61f565122748 100644
--- a/net-analyzer/ntop/ntop-3.1.ebuild
+++ b/net-analyzer/ntop/ntop-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.1.ebuild,v 1.4 2005/02/19 12:00:58 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.1.ebuild,v 1.5 2005/05/10 05:32:43 eldad Exp $
inherit gnuconfig eutils
@@ -63,6 +63,7 @@ src_compile() {
}
src_install() {
+ sed -i Makefile -e 's;mkdir -p $(CFG_DBFILE_DIR);mkdir -p $(DESTDIR)$(CFG_DBFILE_DIR);'
make DESTDIR=${D} install || die "install problem"
# fixme: bad handling of plugins (in /usr/lib with unsuggestive names)