summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-09 11:15:41 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-09 11:15:41 +0000
commite4c81b0bc2716efa11bf8d1b00e85875eeebf250 (patch)
treedeabc0091f54d33db2394038674af106c5b92120 /net-analyzer
parentinitial ebuild, using SLOT technology ;o) (diff)
downloadhistorical-e4c81b0bc2716efa11bf8d1b00e85875eeebf250.tar.gz
historical-e4c81b0bc2716efa11bf8d1b00e85875eeebf250.tar.bz2
historical-e4c81b0bc2716efa11bf8d1b00e85875eeebf250.zip
update ethereal to 0.9.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.1.ebuild48
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.11
2 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.9.1.ebuild b/net-analyzer/ethereal/ethereal-0.9.1.ebuild
new file mode 100644
index 000000000000..6d694dc342b6
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.9.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.1.ebuild,v 1.1 2002/02/09 11:15:41 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A commercial-quality network protocol analyzer"
+SRC_URI="http://ethereal.zing.org/distribution/${P}.tar.gz"
+HOMEPAGE="http://ethereal.zing.org/"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ >=dev-libs/glib-1.2.0
+ snmp? ( >=net-analyzer/ucd-snmp-4.1.2 )
+ X? ( virtual/x11 >=x11-libs/gtk+-1.2.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ sys-devel/bison
+ sys-devel/flex
+ >=net-libs/libpcap-0.5.2"
+
+src_compile() {
+
+ local myconf
+ use ssl || myconf="${myconf} --without-ssl"
+ use snmp || myconf="${myconf} --disable-snmp"
+ use X || myconf="${myconf} --disable-ethereal"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} \
+ --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
+ --mandir=/usr/share/man --sysconfdir=/etc/ethereal \
+ --enable-pcap --enable-zlib --enable-ipv6 || die
+
+ make || die "compile problem"
+}
+
+src_install() {
+
+ dodir /usr/lib/ethereal/plugins/${PV}
+
+ make plugindir=${D}/usr/lib/ethereal/plugins/${PV} \
+ prefix=${D}/usr sysconfdir=${D}/etc/ethereal \
+ mandir=${D}/usr/share/man install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.1 b/net-analyzer/ethereal/files/digest-ethereal-0.9.1
new file mode 100644
index 000000000000..fcd89e70b3ab
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.9.1
@@ -0,0 +1 @@
+MD5 d358941f978bff598672c618df044195 ethereal-0.9.1.tar.gz 2756335