summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-14 14:15:33 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-14 14:15:33 +0000
commit171ac8b514a53958217030b88b48976e1a894baa (patch)
tree032b33412cddbf682f476f4ccfbd26fdafbe51f7 /net-analyzer
parentAnother copyright fix (diff)
downloadhistorical-171ac8b514a53958217030b88b48976e1a894baa.tar.gz
historical-171ac8b514a53958217030b88b48976e1a894baa.tar.bz2
historical-171ac8b514a53958217030b88b48976e1a894baa.zip
Version bump for bug 95957.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/amap/Manifest10
-rw-r--r--net-analyzer/amap/amap-5.1.ebuild61
-rw-r--r--net-analyzer/amap/files/digest-amap-5.11
3 files changed, 72 insertions, 0 deletions
diff --git a/net-analyzer/amap/Manifest b/net-analyzer/amap/Manifest
index f90974f4197f..7a5819a9dd6b 100644
--- a/net-analyzer/amap/Manifest
+++ b/net-analyzer/amap/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 bf0cd3ae53ef3b3f2ef5bab3e309c44b amap-5.1.ebuild 1545
MD5 701ffa0a03c07892f770bf5419333da4 amap-4.7.ebuild 1393
MD5 44e2be0bf7faf3e254623622502ff55b amap-4.8-r1.ebuild 1470
@@ -13,3 +16,10 @@ MD5 b078c53b085eba48231c7df7123766b5 files/amap-5.0-gcc4.patch 15883
MD5 cc27dde4b08677a49290c397dc162be8 files/amap-4.8-gcc4.patch 2460
MD5 a11774428cb7e97a81107a22682d1798 files/4.8-system-pcre.patch 1232
MD5 36fabda09cbfbb3c4c9eab818e99a501 files/amap-4.8-fix-icky-lvalue-casts.diff 7058
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCrubfEZCkKN40op4RAgsXAJ456HJ4vU/WAhtcUImamzSYfXjXGACfZMVE
+/OODPqdmLZPWikKiC2XuspQ=
+=hVeI
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/amap/amap-5.1.ebuild b/net-analyzer/amap/amap-5.1.ebuild
new file mode 100644
index 000000000000..a39221ec62f1
--- /dev/null
+++ b/net-analyzer/amap/amap-5.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/amap/amap-5.1.ebuild,v 1.1 2005/06/14 14:15:33 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="A network scanning tool for pentesters"
+HOMEPAGE="http://www.thc.org/thc-amap/"
+SRC_URI="http://www.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ ssl? ( >=dev-libs/openssl-0.9.6j )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ chmod 755 .
+ sed -i -e "s:etc/:share/amap/:g" \
+ amap-lib.c || die "sed amap-lib.c failed"
+ sed -i 's:/usr/local:/usr:' amap.h || die "sed amap.h failed"
+ sed -i '/DATADIR/s:/etc:/share/amap:' \
+ Makefile.am || die "sed Makefile.am failed"
+ rm -rf pcre-3.9
+
+ epatch ${FILESDIR}/4.8-system-pcre.patch
+ epatch ${FILESDIR}/${PN}-5.0-gcc4.patch
+}
+
+src_compile() {
+ # has it's own stupid custom configure script
+ ./configure || die "configure failed"
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ Makefile || die "pruning vars"
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DOPENSSL:' \
+ -e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
+ Makefile || die "adding ssl"
+ fi
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin amap amapcrap || die "dobin failed"
+ insinto /usr/share/amap
+ doins appdefs.* || die "doins failed"
+
+ doman ${PN}.1
+ dodoc README TODO CHANGES
+}
diff --git a/net-analyzer/amap/files/digest-amap-5.1 b/net-analyzer/amap/files/digest-amap-5.1
new file mode 100644
index 000000000000..22b67cec2dfb
--- /dev/null
+++ b/net-analyzer/amap/files/digest-amap-5.1
@@ -0,0 +1 @@
+MD5 6d0a1c54d07967dfc10768a5ca6ee16b amap-5.1.tar.gz 261983