summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2005-04-26 21:46:18 +0000
committerBrian Jackson <iggy@gentoo.org>2005-04-26 21:46:18 +0000
commit39c1361ba19ac2c7ce98105eed15da7d373a1211 (patch)
tree942dc5af7a5eab232065dc2560303f00b8a3471f /net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild
parentVersion bump. Removed old ebuild. (diff)
downloadhistorical-39c1361ba19ac2c7ce98105eed15da7d373a1211.tar.gz
historical-39c1361ba19ac2c7ce98105eed15da7d373a1211.tar.bz2
historical-39c1361ba19ac2c7ce98105eed15da7d373a1211.zip
Initial commit to Gentoo\'s cvs, huge thanks to Norguhtar \<sauronATinfocentr.ru\> \(bug \#90005\), and all the people on bug \#58123
Package-Manager: portage-2.0.51.20-r4
Diffstat (limited to 'net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild')
-rw-r--r--net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild b/net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild
new file mode 100644
index 000000000000..7cb7cfb08188
--- /dev/null
+++ b/net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/zabbix-agent-1.1_alpha7.ebuild,v 1.1 2005/04/26 21:46:18 iggy Exp $
+
+inherit eutils
+
+MY_P=${PN//-agent/}
+MY_PV=${PV//_/}
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers. Agent part."
+
+HOMEPAGE="http://zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${MY_P}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~sparc ~amd64"
+
+IUSE=""
+
+DEPEND=""
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:"
+RDEPEND=""
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+S=${WORKDIR}/${MY_P}-${MY_PV}
+
+pkg_setup() {
+ enewgroup zabbix
+ enewuser zabbix -1 /bin/false /dev/null zabbix
+}
+
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /etc/zabbix /var/log/zabbix /var/run/zabbix
+ keepdir /etc/zabbix /var/log/zabbix /var/run/zabbix
+ insinto /etc/zabbix
+ doins ${FILESDIR}/${PV}/zabbix_agent.conf ${FILESDIR}/${PV}/zabbix_agentd.conf
+ insinto /etc/conf.d
+ doins ${FILESDIR}/${PV}/conf.d/zabbix-agentd
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/${PV}/init.d/zabbix-agentd
+ dosbin bin/zabbix_agent bin/zabbix_agentd bin/zabbix_sender
+ fowners zabbix:zabbix /etc/zabbix /var/log/zabbix /var/run/zabbix /etc/zabbix/zabbix_agent.conf /etc/zabbix/zabbix_agentd.conf
+ fperms 0640 /etc/zabbix/zabbix_agent.conf /etc/zabbix/zabbix_agentd.conf
+ fperms 0750 /var/log/zabbix /var/run/zabbix
+}