summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-17 18:45:05 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-17 18:45:05 +0000
commite8daf6778cd5485d9e6aaac29db58e2b4e47599b (patch)
tree150740df35457674eb1c1427fe93f53f17d02362 /net-analyzer/yersinia/yersinia-0.7.1.ebuild
parentNeeds pango with X. Bug #247004 (diff)
downloadhistorical-e8daf6778cd5485d9e6aaac29db58e2b4e47599b.tar.gz
historical-e8daf6778cd5485d9e6aaac29db58e2b4e47599b.tar.bz2
historical-e8daf6778cd5485d9e6aaac29db58e2b4e47599b.zip
Version bump. Fixed >libpcap-1.0.0 build issue, bug #247133, thank Willard Dawson for report.
Package-Manager: portage-2.2_rc14/cvs/Linux 2.6.26-openvz.git-35f41f1 i686
Diffstat (limited to 'net-analyzer/yersinia/yersinia-0.7.1.ebuild')
-rw-r--r--net-analyzer/yersinia/yersinia-0.7.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/yersinia/yersinia-0.7.1.ebuild b/net-analyzer/yersinia/yersinia-0.7.1.ebuild
new file mode 100644
index 000000000000..4629ec196396
--- /dev/null
+++ b/net-analyzer/yersinia/yersinia-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/yersinia/yersinia-0.7.1.ebuild,v 1.1 2008/11/17 18:45:04 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="A layer 2 attack framework"
+HOMEPAGE="http://www.yersinia.net/"
+SRC_URI="http://www.yersinia.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk ncurses"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.5 )
+ gtk? ( =x11-libs/gtk+-2* )
+ >=net-libs/libnet-1.1.2
+ >=net-libs/libpcap-0.9.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-no-ncurses.patch"
+ sed -e "s:^\(CFLAGS = \).*:\1${CFLAGS}:" -i src/Makefile.in
+}
+
+src_compile() {
+ econf \
+ --enable-admin \
+ --with-pcap-includes=/usr/include \
+ $(use_with ncurses) \
+ $(use_enable gtk)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FAQ README THANKS TODO || die
+}