summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-10-30 00:17:12 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-10-30 00:17:12 +0000
commit6a6852a6c88a2c32036b86a4ad7084560053b9e7 (patch)
treefe560b707898dc98b09672ee1d8977ce49d9c810 /net-analyzer/traffic-vis/traffic-vis-0.35.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-6a6852a6c88a2c32036b86a4ad7084560053b9e7.tar.gz
historical-6a6852a6c88a2c32036b86a4ad7084560053b9e7.tar.bz2
historical-6a6852a6c88a2c32036b86a4ad7084560053b9e7.zip
*** empty log message ***
Diffstat (limited to 'net-analyzer/traffic-vis/traffic-vis-0.35.ebuild')
-rw-r--r--net-analyzer/traffic-vis/traffic-vis-0.35.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/traffic-vis/traffic-vis-0.35.ebuild b/net-analyzer/traffic-vis/traffic-vis-0.35.ebuild
new file mode 100644
index 000000000000..a9435befdb6e
--- /dev/null
+++ b/net-analyzer/traffic-vis/traffic-vis-0.35.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/traffic-vis-0.35.ebuild,v 1.1 2003/10/30 00:17:12 lisa Exp $
+
+DESCRIPTION="Generate traffic stats in html, ps, text and gif format"
+HOMEPAGE="http://www.mindrot.org/traffic-vis.html"
+SRC_URI="http://www.mindrot.org/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="gif"
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.4
+ gif? ( media-libs/netpbm
+ app-text/ghostscript
+ dev-lang/perl )
+ >=dev-libs/glib-1.1.15"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ make || die "make failed"
+}
+
+src_install() {
+ dosbin collector/traffic-collector
+ doman collector/traffic-collector.8
+
+ for mybin in `use gif >/dev/null && echo "frontends/traffic-togif"` \
+ frontends/traffic-tohtml \
+ frontends/traffic-tops \
+ frontends/traffic-totext \
+ sort/traffic-sort \
+ utils/traffic-exclude \
+ utils/traffic-resolve ; do
+
+ dobin ${mybin}
+ doman ${mybin}.8
+ done
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/traffic-vis.init.d traffic-vis
+ insinto /etc/conf.d
+ newins ${FILESDIR}/traffic-vis.conf.d traffic-vis
+
+ dodoc TODO README COPYING BUGS CHANGELOG
+}