summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:03:49 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:03:49 +0000
commit5b197d50c8e7073465eb76e576f1651ff9d01f9f (patch)
tree875e3bc59906169405fa9fe6df2975dbac0a265f /net-analyzer/sarg
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-5b197d50c8e7073465eb76e576f1651ff9d01f9f.tar.gz
historical-5b197d50c8e7073465eb76e576f1651ff9d01f9f.tar.bz2
historical-5b197d50c8e7073465eb76e576f1651ff9d01f9f.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'net-analyzer/sarg')
-rw-r--r--net-analyzer/sarg/sarg-1.2.2.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/net-analyzer/sarg/sarg-1.2.2.ebuild b/net-analyzer/sarg/sarg-1.2.2.ebuild
index 5e653016dbe0..f90d5505f061 100644
--- a/net-analyzer/sarg/sarg-1.2.2.ebuild
+++ b/net-analyzer/sarg/sarg-1.2.2.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-1.2.2.ebuild,v 1.2 2002/11/14 10:15:25 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-1.2.2.ebuild,v 1.3 2002/11/30 02:03:49 vapier Exp $
DESCRIPTION="Sarg (Squid Analysis Report Generator) is a tool that allows you to view where your users are going to on the Internet."
HOMEPAGE="http://web.onda.com.br/orso/sarg.html"
SRC_URI="http://web.onda.com.br/orso/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+
DEPEND=""
RDEPEND=">=net-www/squid-2.4.7"
-S="${WORKDIR}/${P}"
src_compile() {
- rm -rf config.cache
- ./configure \
- --enable-bindir=/usr/bin \
- --enable-sysconfdir=/etc/sarg || die "./configure failed"
- emake || die
+ rm -rf config.cache
+ ./configure \
+ --enable-bindir=/usr/bin \
+ --enable-sysconfdir=/etc/sarg || die "./configure failed"
+ emake || die
}
-src_install () {
- mkdir ${D}/etc
- mkdir ${D}/etc/sarg
- mkdir ${D}/usr
- mkdir ${D}/usr/bin
- make \
- BINDIR=${D}/usr/bin \
- SYSCONFDIR=${D}/etc/sarg \
- install || die
+src_install() {
+ dodir /etc/sarg /usr/bin
+ make \
+ BINDIR=${D}/usr/bin \
+ SYSCONFDIR=${D}/etc/sarg \
+ install || die
}
-