summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-08 08:49:04 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-08 08:49:04 +0000
commitc0a56e7a870996d61c6dfec34ed277818c06882f (patch)
treeb169944099d8c5c206af94f3f2e35a81ead2b6a0 /net-analyzer/rrdtool
parentRemoved unnecessary "cd ${S}" under src_install(). (diff)
downloadhistorical-c0a56e7a870996d61c6dfec34ed277818c06882f.tar.gz
historical-c0a56e7a870996d61c6dfec34ed277818c06882f.tar.bz2
historical-c0a56e7a870996d61c6dfec34ed277818c06882f.zip
Initial import of RRDTool into portage tree.
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/files/digest-rrdtool-1.0.281
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.28.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/rrdtool/files/digest-rrdtool-1.0.28 b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.28
new file mode 100644
index 000000000000..82c51611f4ac
--- /dev/null
+++ b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.28
@@ -0,0 +1 @@
+MD5 4db8949675ccb97cd289fae96fb3dbb0 rrdtool-1.0.28.tar.gz
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.28.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.28.ebuild
new file mode 100644
index 000000000000..052d0db8c722
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.0.28.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.28.ebuild,v 1.1 2000/11/08 08:49:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A system to store and display time-series data"
+SRC_URI="http://ee-staff.ethz.ch/~oetiker/webtools/rrdtool/pub/${A}"
+HOMEPAGE="http://ee-staff.ethz.ca/~oetiker/webtools/rrdtool/"
+
+DEPEND=">=sys-devel/perl-5.6.0
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libgd-1.8.3
+ >=media-libs/libpng-1.0.8"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/opt/rrdtool --host=${CHOST}
+ try make
+}
+
+src_install () {
+ try make prefix=${D}/opt/rrdtool install
+ try make PREFIX=${D}/usr site-perl-install
+}