summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-17 21:51:14 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-17 21:51:14 +0000
commitf98a05754d838aabf67d4366599abea0bb3ab74b (patch)
tree014d2c0886fb135c2d8cb33f3eb5c9cbdcc04132 /net-analyzer/nethogs
parentMinor ebuild fixes (diff)
downloadhistorical-f98a05754d838aabf67d4366599abea0bb3ab74b.tar.gz
historical-f98a05754d838aabf67d4366599abea0bb3ab74b.tar.bz2
historical-f98a05754d838aabf67d4366599abea0bb3ab74b.zip
Fix hardcoded CFLAGS and gcc
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-analyzer/nethogs')
-rw-r--r--net-analyzer/nethogs/ChangeLog5
-rw-r--r--net-analyzer/nethogs/Manifest6
-rw-r--r--net-analyzer/nethogs/nethogs-0.6.0.ebuild18
3 files changed, 16 insertions, 13 deletions
diff --git a/net-analyzer/nethogs/ChangeLog b/net-analyzer/nethogs/ChangeLog
index d72223027c18..b4dd184058b1 100644
--- a/net-analyzer/nethogs/ChangeLog
+++ b/net-analyzer/nethogs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nethogs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/ChangeLog,v 1.4 2005/08/16 19:24:33 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/ChangeLog,v 1.5 2005/09/17 21:51:14 vanquirius Exp $
+
+ 17 Sep 2005; Marcelo Goes <vanquirius@gentoo.org> nethogs-0.6.0.ebuild:
+ Fix hardcoded CFLAGS and gcc.
16 Aug 2005; Simon Stelling <blubb@gentoo.org> nethogs-0.6.0.ebuild:
added ~amd64 keyword
diff --git a/net-analyzer/nethogs/Manifest b/net-analyzer/nethogs/Manifest
index 956075d9ab97..d1cb7dcecff7 100644
--- a/net-analyzer/nethogs/Manifest
+++ b/net-analyzer/nethogs/Manifest
@@ -1,5 +1,5 @@
-MD5 aa3afd25d00bddd50729400748c16877 ChangeLog 950
+MD5 32781c8773f855aa3110ec67c1c2b4f9 nethogs-0.6.0.ebuild 988
+MD5 19e68a6b745eb6931ddfab962e9db914 ChangeLog 1062
MD5 1385d77b0c1cbc2ad11db1d3abea9721 metadata.xml 735
-MD5 06b135339db764cda7c09916062ad9c3 nethogs-0.6.0.ebuild 871
-MD5 91d6d413a6fddc0318223e2c73caa452 files/digest-nethogs-0.6.0 64
MD5 ee1f4e4bcff506362fd7463b85016f54 files/nethogs-0.6.0-gcc34.diff 397
+MD5 91d6d413a6fddc0318223e2c73caa452 files/digest-nethogs-0.6.0 64
diff --git a/net-analyzer/nethogs/nethogs-0.6.0.ebuild b/net-analyzer/nethogs/nethogs-0.6.0.ebuild
index 05c4d2426817..37f161c9c472 100644
--- a/net-analyzer/nethogs/nethogs-0.6.0.ebuild
+++ b/net-analyzer/nethogs/nethogs-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.0.ebuild,v 1.4 2005/08/16 19:24:33 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.0.ebuild,v 1.5 2005/09/17 21:51:14 vanquirius Exp $
-inherit eutils
+inherit eutils toolchain-funcs
HOMEPAGE="http://nethogs.sf.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -14,18 +14,18 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="virtual/libpcap"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc34.diff
+ unpack ${A}; cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc34.diff"
+ # fix hardcoded CFLAGS and CC
+ sed -i -e "s:-O2:${CFLAGS}:g" Makefile || die
+ sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
+ sed -i -e "s:gcc:$(tc-getCC):g" Makefile || die
}
src_compile() {
- # There is currently no configure script within the nethogs package:
- # econf || die
-
emake || die "emake failed"
}