summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-07-01 16:30:18 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-07-01 16:30:18 +0000
commita4b9fd01af7fc2ee9770d4c9e9750df5ef55d271 (patch)
tree795b5215b554ca2ecde2839f35f1f34f78ec19c4 /net-analyzer/nbaudit
parentUpdated docs to include emerging the kernel, using inet.dhcp_eth0, (diff)
downloadhistorical-a4b9fd01af7fc2ee9770d4c9e9750df5ef55d271.tar.gz
historical-a4b9fd01af7fc2ee9770d4c9e9750df5ef55d271.tar.bz2
historical-a4b9fd01af7fc2ee9770d4c9e9750df5ef55d271.zip
polaris from #gentoo did a great job on these I think he's prolly ready to
be a developer if he want to.
Diffstat (limited to 'net-analyzer/nbaudit')
-rw-r--r--net-analyzer/nbaudit/files/digest-nbaudit-1.01
-rw-r--r--net-analyzer/nbaudit/nbaudit-1.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/nbaudit/files/digest-nbaudit-1.0 b/net-analyzer/nbaudit/files/digest-nbaudit-1.0
new file mode 100644
index 000000000000..015acf744677
--- /dev/null
+++ b/net-analyzer/nbaudit/files/digest-nbaudit-1.0
@@ -0,0 +1 @@
+MD5 b8e020ac21e35caa35a8bbd99e41b5e4 nat10.tgz
diff --git a/net-analyzer/nbaudit/nbaudit-1.0.ebuild b/net-analyzer/nbaudit/nbaudit-1.0.ebuild
new file mode 100644
index 000000000000..d5a9e2158783
--- /dev/null
+++ b/net-analyzer/nbaudit/nbaudit-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+
+# Its officially called nat10 but the name conflicts with other projects
+# so I'm following the *BSDs suggestion of calling it nbaudit
+
+A=nat10.tgz
+P=nat10
+S=${WORKDIR}/${P}
+DESCRIPTION="NetBIOS file sharing services scanner (nat10)"
+SRC_URI="http://www.tux.org/pub/security/secnet/tools/nat10/${A}"
+HOMEPAGE="http://www.tux.org/pub/security/secnet/tools/nat10"
+
+DEPEND=""
+
+src_compile() {
+
+ cd ${S}
+
+ mv Makefile Makefile.old
+ sed -e "s/# FLAGSM = -DLINUX -DSHADOW_PWD/FLAGSM = -DLINUX -DSHADOW_PWD -DNO_ASMSIGNALH/" -e "s/# LIBSM = -lshadow/LIBSM = -lshadow/" Makefile.old > Makefile
+
+ # sed seems to hang if I do all three at once... oh well
+ mv Makefile Makefile.old
+ sed -e "s/CFLAGS = /CFLAGS = ${CFLAGS} /" Makefile.old > Makefile
+
+ try make all
+
+}
+
+src_install () {
+ cd ${S}
+
+ into /usr
+
+ dobin nat
+ doman nat.1
+ dodoc README COPYING
+}