summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-12-17 23:30:56 +0000
committerEldad Zack <eldad@gentoo.org>2004-12-17 23:30:56 +0000
commite8df87f4aba44ff0476d99c038b04806eb55ef03 (patch)
treeedc3618282d5d16540e72a06085292926823b0ff /net-analyzer/mtr/mtr-0.64.ebuild
parentRemoved comments from metadata.xml. (diff)
downloadhistorical-e8df87f4aba44ff0476d99c038b04806eb55ef03.tar.gz
historical-e8df87f4aba44ff0476d99c038b04806eb55ef03.tar.bz2
historical-e8df87f4aba44ff0476d99c038b04806eb55ef03.zip
Version bump. Fixed lazy-binding suid issue.
Diffstat (limited to 'net-analyzer/mtr/mtr-0.64.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-0.64.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/mtr/mtr-0.64.ebuild b/net-analyzer/mtr/mtr-0.64.ebuild
index a8517d1c1175..3fc76e8353da 100644
--- a/net-analyzer/mtr/mtr-0.64.ebuild
+++ b/net-analyzer/mtr/mtr-0.64.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.64.ebuild,v 1.7 2004/11/30 20:22:01 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.64.ebuild,v 1.8 2004/12/17 23:30:56 eldad Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="My TraceRoute. Excellent network diagnostic tool."
HOMEPAGE="http://www.bitwizard.nl/mtr/"
@@ -21,11 +21,14 @@ src_compile() {
local myconf
use gtk || myconf="${myconf} --without-gtk"
+ append-ldflags -Wl,-z,now
+
epatch ${FILESDIR}/mtr-ac-res_mkquery.patch
autoconf
econf ${myconf} \
`use_enable gtk2` || die
+
emake || die
}