summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-09 03:24:38 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-09 03:24:38 +0000
commitead79edbca82a65b7f6875e4f28c31aed8a4cbc0 (patch)
tree4dece98f86c1968e639938b33a8763b68c8a6e4f /net-analyzer/dsniff
parentNew upstream version; Keywording =dev-lisp/clisp-2.34-r1 stable for x86. (diff)
downloadhistorical-ead79edbca82a65b7f6875e4f28c31aed8a4cbc0.tar.gz
historical-ead79edbca82a65b7f6875e4f28c31aed8a4cbc0.tar.bz2
historical-ead79edbca82a65b7f6875e4f28c31aed8a4cbc0.zip
Made ebuild DEPEND on ~sys-libs/db-3.2.9 instead of building its own copy
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-analyzer/dsniff')
-rw-r--r--net-analyzer/dsniff/ChangeLog7
-rw-r--r--net-analyzer/dsniff/Manifest4
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r6.ebuild48
-rw-r--r--net-analyzer/dsniff/files/digest-dsniff-2.3-r61
4 files changed, 58 insertions, 2 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index decc33281142..8276fa07a13b 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.18 2005/06/27 19:28:40 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.19 2005/09/09 03:24:38 vanquirius Exp $
+
+*dsniff-2.3-r6 (09 Sep 2005)
+
+ 09 Sep 2005; Marcelo Goes <vanquirius@gentoo.org> +dsniff-2.3-r6.ebuild:
+ Made ebuild DEPEND on ~sys-libs/db-3.2.9 instead of building its own copy.
*dsniff-2.3-r5 (27 Jun 2005)
diff --git a/net-analyzer/dsniff/Manifest b/net-analyzer/dsniff/Manifest
index 1570c3bc762a..dfea72bac123 100644
--- a/net-analyzer/dsniff/Manifest
+++ b/net-analyzer/dsniff/Manifest
@@ -1,8 +1,10 @@
+MD5 0e532c62fdcfa0d6e65b1b377d430cf1 dsniff-2.3-r6.ebuild 1408
MD5 33429f33cb307d7a7ff109b9dd5424d4 dsniff-2.3-r5.ebuild 2306
-MD5 b82769f7370ba8acf1894e7ccd008a4e ChangeLog 2301
+MD5 520ae7c9498ddc64b378d276f812270b ChangeLog 2484
MD5 bb880c49bdffe94226562c9f6b06e0e7 metadata.xml 719
MD5 48eead686457507a20e6688478e2a010 dsniff-2.3-r4.ebuild 2227
MD5 5c5bea8cc4846925ba48ba5c9ea83341 files/digest-dsniff-2.3-r4 123
MD5 5c5bea8cc4846925ba48ba5c9ea83341 files/digest-dsniff-2.3-r5 123
+MD5 0e5d8e4adda8f4876e972a02bed13cc3 files/digest-dsniff-2.3-r6 62
MD5 9206faea6a9be25f7d1aa0ac0a2ff6e3 files/2.3-libnet-1.0.patch 6110
MD5 f41ad0aeacc05042ec27551b257845d3 files/2.3-makefile.patch 1531
diff --git a/net-analyzer/dsniff/dsniff-2.3-r6.ebuild b/net-analyzer/dsniff/dsniff-2.3-r6.ebuild
new file mode 100644
index 000000000000..b0d4059a6d03
--- /dev/null
+++ b/net-analyzer/dsniff/dsniff-2.3-r6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r6.ebuild,v 1.1 2005/09/09 03:24:38 vanquirius Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A collection of tools for network auditing and penetration testing"
+HOMEPAGE="http://monkey.org/~dugsong/${PN}/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+LICENSE="DSNIFF"
+SLOT="0"
+KEYWORDS="~amd64 ~alpha ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libpcap
+ <net-libs/libnet-1.1
+ >=net-libs/libnet-1.0.2a-r3
+ >=net-libs/libnids-1.18
+ >=dev-libs/openssl-0.9.6e
+ ~sys-libs/db-3.2.9"
+
+src_unpack() {
+ unpack ${A}
+
+ # Making sure data files get correctly installed and that dsniff
+ # can find them
+ # Working around dsniff b0rky config script
+ # Data stuff goes into /etc/dsniff
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-libnet-1.0.patch
+ sed -i \
+ -e 's:-ldb:-ldb -lpthread:' \
+ -e "s:lib':':" \
+ configure || die "sed configure"
+ sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
+ sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
+ epatch ${FILESDIR}/${PV}-makefile.patch
+
+ # Allow amd64 compilation
+ append-ldflags -lresolv
+}
+
+src_install() {
+ make install install_prefix=${D} || die
+ dodir /etc/dsniff
+ mv ${D}/usr/{dnsspoof.hosts,dsniff.{magic,services}} ${D}/etc/dsniff/
+ dodoc CHANGES README TODO
+}
diff --git a/net-analyzer/dsniff/files/digest-dsniff-2.3-r6 b/net-analyzer/dsniff/files/digest-dsniff-2.3-r6
new file mode 100644
index 000000000000..9942098f31ff
--- /dev/null
+++ b/net-analyzer/dsniff/files/digest-dsniff-2.3-r6
@@ -0,0 +1 @@
+MD5 183e336a45e38013f3af840bddec44b4 dsniff-2.3.tar.gz 126797