summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-11 18:25:29 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-11 18:25:29 +0000
commit2187b5fbfaca7e75d260c138a76c04c9da69bc9d (patch)
tree8d9bbea53a1433174b2a74c8951cfd354728bf47 /media-video
parentcleanup (diff)
downloadhistorical-2187b5fbfaca7e75d260c138a76c04c9da69bc9d.tar.gz
historical-2187b5fbfaca7e75d260c138a76c04c9da69bc9d.tar.bz2
historical-2187b5fbfaca7e75d260c138a76c04c9da69bc9d.zip
cleanup
Diffstat (limited to 'media-video')
-rw-r--r--media-video/transcode/Manifest2
-rw-r--r--media-video/transcode/transcode-0.6.2.ebuild112
2 files changed, 0 insertions, 114 deletions
diff --git a/media-video/transcode/Manifest b/media-video/transcode/Manifest
index 275ebccf2576..bfc52c4e1849 100644
--- a/media-video/transcode/Manifest
+++ b/media-video/transcode/Manifest
@@ -1,11 +1,9 @@
MD5 4dc17c8a1470608ff62ee261b5a1123f ChangeLog 9064
-MD5 df648b9270825d3e3a34a1837dc21306 transcode-0.6.2.ebuild 3120
MD5 94bd38e13fa090bcc32202151996f459 transcode-0.6.3.ebuild 3061
MD5 dda3bcb1982bfd44be27d7b4570b178b transcode-0.6.6.ebuild 3292
MD5 b295e859c3a5d0bdae6bf5d0892e832f transcode-0.6.7.ebuild 3394
MD5 355d99e0b15965c13114774706d15fba transcode-0.6.8.ebuild 3350
MD5 40f99c39a21fb09fb3218e2956d758be files/digest-transcode-0.6.8 68
-MD5 03629a858586307611c7d7c2a2dc1505 files/digest-transcode-0.6.2 68
MD5 225a843999c440c3060e96b9fe6fca35 files/digest-transcode-0.6.3 68
MD5 2e179af41bdf16c1de0a976eb914a141 files/digest-transcode-0.6.6 68
MD5 4a954714299d666fbf12472d96760bed files/digest-transcode-0.6.7 68
diff --git a/media-video/transcode/transcode-0.6.2.ebuild b/media-video/transcode/transcode-0.6.2.ebuild
deleted file mode 100644
index ed096cb915c4..000000000000
--- a/media-video/transcode/transcode-0.6.2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.2.ebuild,v 1.6 2003/02/15 16:53:07 mholzer Exp $
-
-IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
-
-inherit libtool
-
-MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="video stream processing tool"
-SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${MY_P}.tar.gz"
-HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
-
-# Note: transcode can use pretty much any media-related package ever written as
-# a plugin. An exhaustive dep list would make me add about 20-30 packages to
-# portage. perhaps another time :-)
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 -ppc"
-
-DEPEND=">=media-libs/a52dec-0.7.3
- >=media-libs/libdv-0.9.5
- >=dev-lang/nasm-0.98.34
- X? ( virtual/x11 )
- avi? ( <=media-video/avifile-0.7.22
- >=media-video/avifile-0.7.4 )
- dvd? ( media-libs/libdvdread )
- mpeg? ( media-libs/libmpeg3 )
- encode? ( >=media-sound/lame-3.89 )
- sdl? ( media-libs/libsdl )
- quicktime? ( media-libs/quicktime4linux )
- <=media-video/avifile-0.7.22
- >=media-video/avifile-0.7.4
- media-libs/libdvdread
- >=media-video/mplayer-0.90_pre10"
-
-# >=media-video/mplayer-0.90_pre10
-# Most people will want to view their video so
-# I have made mplayer the default as that is what
-# many will use anyway. Due to API changes transcode will
-# now fail to build if an earlier version of mplayer is
-# installed.
-# 2002-11-22 Transcode now requires nasm.
-
-# Dont want to build without these currently
-# avi? ( >=media-video/avifile-0.7.4 )
-# dvd? ( media-libs/libdvdread )"
-
-src_compile() {
-
- # fix invalid paths in .la files of plugins
- elibtoolize
-
- local myconf=""
-
- use mmx \
- && myconf="${myconf} --enable-mmx"
- use mmx || ( use 3dnow || use sse ) \
- || myconf="${myconf} --disable-mmx"
- # Dont disable mmx if 3dnow or sse are requested.
-
- use sse \
- && myconf="${myconf} --enable-sse" \
- || myconf="${myconf} --disable-sse"
-
-# use avi \
-# && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
-# || myconf="${myconf} --without-avifile-mods --disable-avifile6"
-#
-# use dvd \
-# && myconf="${myconf} --with-dvdread" \
-# || myconf="${myconf} --without-dvdread"
-#
-# Dont currently want to build without these
- myconf="${myconf} --with-dvdread --with-avifile-mods --enable-avifile6"
-
- use encode \
- && myconf="${myconf} --with-lame" \
- || myconf="${myconf} --without-lame"
-
- use mpeg \
- && myconf="${myconf} --with-libmpeg3" \
- || myconf="${myconf} --without-libmpeg3"
-
- use quicktime \
- || myconf="${myconf} --without-qt --without-openqt"
-
- use X \
- && myconf="${myconf} --enable-x" \
- || myconf="${myconf} --disable-x"
-
- # Use the MPlayer libpostproc if present
- [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
- [ -f ${ROOT}/usr/include/postprocess.h ] && \
- myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
-
- econf ${myconf} || die
-
- # Do not use emake !!
- make all || die
-}
-
-src_install () {
-
- make \
- DESTDIR=${D} \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog README TODO
-}