summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2007-03-31 19:26:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2007-03-31 19:26:38 +0000
commitccabbf89cce04a63bb93f358b63e291d69271772 (patch)
treef438a19bc431a28d1df3c0bb6eea318fad82b0fd /media-video/vstrip/vstrip-0.8f.ebuild
parentVersion bump. (diff)
downloadhistorical-ccabbf89cce04a63bb93f358b63e291d69271772.tar.gz
historical-ccabbf89cce04a63bb93f358b63e291d69271772.tar.bz2
historical-ccabbf89cce04a63bb93f358b63e291d69271772.zip
Replace dos2unix with edos2unix for bug 162841 and fix missing asm/io.h.
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'media-video/vstrip/vstrip-0.8f.ebuild')
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
index 31ce469f386c..bf73ab98fb40 100644
--- a/media-video/vstrip/vstrip-0.8f.ebuild
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/vstrip-0.8f.ebuild,v 1.3 2005/09/16 02:36:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vstrip/vstrip-0.8f.ebuild,v 1.4 2007/03/31 19:26:38 drac Exp $
inherit eutils
@@ -13,28 +13,27 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-DEPEND="app-text/dos2unix
- app-arch/unzip"
+DEPEND="app-arch/unzip"
RDEPEND=""
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/vstrip-0.8f-gentoo.patch
- dos2unix -q -o *.c *.h
-
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ edos2unix *.c *.h
+
for file in *.c *.h ; do
echo >>$file
done
}
src_compile() {
- emake || die "emake failed"
+ emake || die "emake failed."
}
src_install() {
- dobin vstrip || die "dobin failed"
+ dobin vstrip
}