summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-10 15:56:59 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-10 15:56:59 +0000
commit05d26dfb0487349a46feffd43a6bd258e915f426 (patch)
tree6cad0d3ba6094a9448ce269e54a2e4085a138a2a /media-video/vcdimager/vcdimager-0.7.15.ebuild
parentVersion bumped. (diff)
downloadhistorical-05d26dfb0487349a46feffd43a6bd258e915f426.tar.gz
historical-05d26dfb0487349a46feffd43a6bd258e915f426.tar.bz2
historical-05d26dfb0487349a46feffd43a6bd258e915f426.zip
Version bumped.
Diffstat (limited to 'media-video/vcdimager/vcdimager-0.7.15.ebuild')
-rw-r--r--media-video/vcdimager/vcdimager-0.7.15.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/vcdimager/vcdimager-0.7.15.ebuild b/media-video/vcdimager/vcdimager-0.7.15.ebuild
new file mode 100644
index 000000000000..f838532e208e
--- /dev/null
+++ b/media-video/vcdimager/vcdimager-0.7.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+IUSE="xml2"
+
+DESCRIPTION="GNU VCDimager"
+S=${WORKDIR}/${PN}-${PV}-cdio
+SRC_URI="http://savannah.nongnu.org/download/libcdio/libcdio.pkg/0.6/${PN}-${PV}-cdio.tar.gz"
+HOMEPAGE="http://www.vcdimager.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Ideally this would also include help2man, but it's not yet in portage.
+DEPEND=">=dev-libs/libcdio-0.6
+ xml2? ( >=dev-libs/libxml2-2.3.8 )"
+
+src_compile() {
+ local myopts
+
+ # We disable the xmltest because the configure script includes differently
+ # than the actual XML-frontend C files.
+
+ use xml2 \
+ && myopts="${myopts} --with-xml-prefix=/usr --disable-xmltest" \
+ || myopts="${myopts} --without-xml-frontend"
+
+ econf ${myopts} || die
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog FAQ HACKING INSTALL
+ dodoc NEWS README THANKS TODO
+}