summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-11 20:28:06 +0000
committerChris White <chriswhite@gentoo.org>2005-01-11 20:28:06 +0000
commit84bd1d62a60d92b5034b3f4b2af1da3ad9a4a58b (patch)
tree2e7ff59b1766d27c12f0caeabea905529b4a0bd1 /media-video/lve
parentsparc (diff)
downloadhistorical-84bd1d62a60d92b5034b3f4b2af1da3ad9a4a58b.tar.gz
historical-84bd1d62a60d92b5034b3f4b2af1da3ad9a4a58b.tar.bz2
historical-84bd1d62a60d92b5034b3f4b2af1da3ad9a4a58b.zip
Fixed lots of broken things as far as CFLAGS and configuration.
Diffstat (limited to 'media-video/lve')
-rw-r--r--media-video/lve/ChangeLog7
-rw-r--r--media-video/lve/Manifest16
-rw-r--r--media-video/lve/lve-040322.ebuild16
3 files changed, 31 insertions, 8 deletions
diff --git a/media-video/lve/ChangeLog b/media-video/lve/ChangeLog
index 0bd1567271dd..af49cfd5d228 100644
--- a/media-video/lve/ChangeLog
+++ b/media-video/lve/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/lve
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lve/ChangeLog,v 1.8 2004/09/05 18:06:43 malc Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lve/ChangeLog,v 1.9 2005/01/11 20:28:06 chriswhite Exp $
+
+ 12 Jan 2005; Chris White <chriswhite@gentoo.org> lve-040322.ebuild:
+ Fixed lots of broken things as far as CFLAGS and configuration.
05 Sep 2004; Malcolm Lashley <malc@gentoo.org> lve-040322.ebuild:
~amd64 closes 59091
diff --git a/media-video/lve/Manifest b/media-video/lve/Manifest
index 51c74927737a..70eb022e0b1f 100644
--- a/media-video/lve/Manifest
+++ b/media-video/lve/Manifest
@@ -1,7 +1,17 @@
-MD5 b55c16f22749232e0265af916112f977 ChangeLog 1007
-MD5 a3721a36218490c47de8afdb1082f90f lve-040322.ebuild 1584
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 93ec81f5f922272922cab4c16ef9821f ChangeLog 1150
+MD5 6a1ddd5bf076c02d6743bf2c02b81d65 lve-040322.ebuild 1763
MD5 7300a7b361fa9f48e37722c6952bd432 metadata.xml 158
+MD5 003b0062185efcb0ea5a6115fa8a646a files/0.4.8-gcc3.4-magicF2W.patch 994
MD5 6ac2650d872e299e257254f743e18744 files/040322-lve.patch 405
MD5 645ad6f9362f014e0574e74743244039 files/040322-qtlib.patch 262
MD5 f6a56b9b5742f37d30acfe66fe559962 files/digest-lve-040322 136
-MD5 003b0062185efcb0ea5a6115fa8a646a files/0.4.8-gcc3.4-magicF2W.patch 994
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFB5DV/FdQwWVoAgN4RArnBAJ9zPYUEsWHIfXSkJUeFFfUJSVyobgCdErTf
+qhrA0tEktU0+DIcKv21FBLs=
+=pq7J
+-----END PGP SIGNATURE-----
diff --git a/media-video/lve/lve-040322.ebuild b/media-video/lve/lve-040322.ebuild
index 792d940f8f93..8ab0aa902665 100644
--- a/media-video/lve/lve-040322.ebuild
+++ b/media-video/lve/lve-040322.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lve/lve-040322.ebuild,v 1.8 2004/09/05 18:06:43 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/lve/lve-040322.ebuild,v 1.9 2005/01/11 20:28:06 chriswhite Exp $
inherit eutils gcc
@@ -49,7 +49,17 @@ src_unpack() {
src_compile() {
cd ${WORKDIR}/lve
- make || die
+ make config
+
+ cd src
+ make global_config
+ cd ..
+
+ sed -e "s:CFLAGS.*:CFLAGS = ${CFLAGS}:" \
+ -i src/global_config \
+ || die "Could not patch in CFLAGS"
+
+ make CLFAGS="${CFLAGS}" || die
}
src_install() {