summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-05-11 20:49:53 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-05-11 20:49:53 +0000
commitfc74852d0d08c1afdc27e9a3fb2a76124aa09fce (patch)
treec8c2cf1ef1da18a4ed9f1942ae1f4b33ef4b9ebc /media-tv
parentfix tab (diff)
downloadhistorical-fc74852d0d08c1afdc27e9a3fb2a76124aa09fce.tar.gz
historical-fc74852d0d08c1afdc27e9a3fb2a76124aa09fce.tar.bz2
historical-fc74852d0d08c1afdc27e9a3fb2a76124aa09fce.zip
re-written ebuild. doesn't use the eclass. fixes all known issues
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfrontend/ChangeLog8
-rw-r--r--media-tv/mythfrontend/Manifest10
-rw-r--r--media-tv/mythfrontend/files/digest-mythfrontend-0.18-r11
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.18-r1.ebuild134
4 files changed, 148 insertions, 5 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index f50056482207..b2ca92c8b808 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.35 2005/04/27 02:54:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.36 2005/05/11 20:49:53 cardoe Exp $
+
+*mythfrontend-0.18-r1 (11 May 2005)
+
+ 11 May 2005; <cardoe@gentoo.org> +mythfrontend-0.18-r1.ebuild:
+ rewritten ebuild. fixes many, if not all of the issues.
+ mmx/distcc/ccache/cflags
27 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
mythfrontend-0.18.ebuild:
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
index dce4c2829f9f..54513818f4c7 100644
--- a/media-tv/mythfrontend/Manifest
+++ b/media-tv/mythfrontend/Manifest
@@ -1,18 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 3c2e7886a4fe99cbd1249117ca41fed3 ChangeLog 5585
+MD5 956de2d009468d5a4701e3523b62b80e ChangeLog 5769
MD5 f62db0df6ee8ee1d4fe7b9c3d74432a7 metadata.xml 222
MD5 0a31ca05a47f289619d2b8d77cfbff52 mythfrontend-0.16.ebuild 5726
MD5 b4f7a9d2d6d8b6eef2ff8621f2ea2898 mythfrontend-0.17.ebuild 6151
MD5 55ebeee2ac036a5dc7cef19c3c08a57a mythfrontend-0.18.ebuild 3410
+MD5 0e4bec4584bc45ccf98ef6e6b05dde25 mythfrontend-0.18-r1.ebuild 3651
MD5 fb4505fe7e8b832e115d777bf836d3bc files/digest-mythfrontend-0.16 66
MD5 590c9a6a89442b347c3a5f52d1781351 files/digest-mythfrontend-0.17 66
MD5 67c40a05f5751719f170820c4d50c9c6 files/digest-mythfrontend-0.18 65
+MD5 67c40a05f5751719f170820c4d50c9c6 files/digest-mythfrontend-0.18-r1 65
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCbv/BArHZZzCEUG0RApd2AJ9rudPNSwNDShBHxMUMK2ozRCWbjwCdF2Jn
-7n2jzgXXf4WxAEN8zF2ZzYA=
-=gPYa
+iD8DBQFCgnAOBtvusYtCZMsRAhDNAJ0cqJy4zZ4p5Uc9YWpILHbSOZtbqQCfY1zI
+aVE7qctavnCCkLp9Q8xBbIg=
+=EMd0
-----END PGP SIGNATURE-----
diff --git a/media-tv/mythfrontend/files/digest-mythfrontend-0.18-r1 b/media-tv/mythfrontend/files/digest-mythfrontend-0.18-r1
new file mode 100644
index 000000000000..af9b82960007
--- /dev/null
+++ b/media-tv/mythfrontend/files/digest-mythfrontend-0.18-r1
@@ -0,0 +1 @@
+MD5 8480c534508a2530c1ba35d295870faf mythtv-0.18.tar.bz2 8801515
diff --git a/media-tv/mythfrontend/mythfrontend-0.18-r1.ebuild b/media-tv/mythfrontend/mythfrontend-0.18-r1.ebuild
new file mode 100644
index 000000000000..699ab954bdb9
--- /dev/null
+++ b/media-tv/mythfrontend/mythfrontend-0.18-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.18-r1.ebuild,v 1.1 2005/05/11 20:49:53 cardoe Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="Homebrew PVR project"
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="alsa altivec arts cle266 debug dvb ieee1394 jack joystick lcd lirc mmx nvidia oggvorbis opengl oss xv"
+
+DEPEND=">=media-libs/freetype-2.0
+ >=media-sound/lame-3.93.1
+ virtual/x11
+ >=x11-libs/qt-3.1.1
+ dev-db/mysql
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ arts? ( kde-base/arts )
+ dvb? ( media-libs/libdvb )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )
+ oggvorbis? ( media-libs/libvorbis )
+ opengl? ( virtual/opengl )
+ ieee1394? ( >=sys-libs/libraw1394-1.2.0 )
+ || ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.34 )"
+
+# ieee1394 also needs >=sys-libs/libiec61883-1.0.0
+
+RDEPEND="${DEPEND}
+ !media-tv/mythtv"
+
+pkg_setup() {
+
+ if ! built_with_use x11-libs/qt mysql ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs MySQL support"
+ fi
+
+ if use nvidia; then
+ echo
+ ewarn "You enabled the 'nvidia' USE flag, you must have a GeForce 4 or"
+ ewarn "greater to use this. Otherwise, you'll have crashes with MythTV"
+ echo
+ fi
+
+ einfo
+ einfo "Please note, this ebuild does not use your CFLAGS and CXXFLAGS. It determines"
+ einfo "a sane set and uses those. Please do not attempt to override this behavior."
+ einfo
+
+}
+
+# memory in case I ever bring it back
+#src_unpack() {
+# unpack ${A}
+#
+# # Fix bugs 40964 and 42943.
+# filter-flags -fforce-addr -fPIC -momit-leaf-frame-pointer
+# is-flag "-fomit-frame-pointer" || append-flags "-fomit-frame-pointer"
+#}
+
+src_compile() {
+ use cle266 && use nvidia && die "You can not have USE="cle266" and USE="nvidia" at the same time. Must disable one or the other."
+ local myconf="$(use_enable altivec)
+ $(use_enable oss audio-oss)
+ $(use_enable alsa audio-alsa)
+ $(use_enable arts audio-arts)
+ $(use_enable jack audio-jack)
+ $(use_enable lirc)
+ $(use_enable joystick joystick-menu)
+ $(use_enable cle266 xvmc-vld)
+ $(use_enable dvb)
+ $(use_enable dvb dvb-eit)
+ --dvb-path=/usr/include
+ $(use_enable opengl opengl-vsync)
+ $(use_enable oggvorbis vorbis)
+ $(use_enable nvidia xvmc)
+ $(use_enable xv)
+ --disable-directfb
+ --enable-x11
+ --enable-proc-opt"
+
+ if use mmx || use amd64; then
+ myconf="${myconf} --enable-mmx"
+ else
+ myconf="${myconf} --disable-mmx"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --compile-type=debug"
+ else
+ myconf="${myconf} --compile-type=release"
+ fi
+
+ hasq distcc ${FEATURES} || myconf="${myconf} --disable-distcc"
+ hasq ccache ${FEATURES} || myconf="${myconf} --distable-ccache"
+
+ # depends on bug # 89799
+ # $(use_enable ieee1394 firewire)
+
+ ##Backend Removal
+ cd ${S}
+ sed -e "s:CONFIG += linux backend:CONFIG += linux:" \
+ -i 'settings.pro' || die "Removal of mythbackend failed"
+
+ # let MythTV come up with our CFLAGS. Upstream will support this
+ CFLAGS=""
+ CXXFLAGS=""
+ econf ${myconf} || die "configure died"
+
+ qmake -o "Makefile" mythtv.pro || die "qmake failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ einstall INSTALL_ROOT="${D}" || die "install failed"
+ for doc in AUTHORS COPYING FAQ UPGRADING ChangeLog README; do
+ test -e "${doc}" && dodoc ${doc}
+ done
+
+ dodoc keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+
+ keepdir /var/log/mythtv
+}