summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-14 11:04:31 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-14 11:04:31 +0000
commitdae39b8bec98db0840036369354c379aae87b847 (patch)
tree01f8981648f30f27c41a561ace86c8aea832ae81 /media-tv/mythtv
parentApply upstream patch (diff)
downloadhistorical-dae39b8bec98db0840036369354c379aae87b847.tar.gz
historical-dae39b8bec98db0840036369354c379aae87b847.tar.bz2
historical-dae39b8bec98db0840036369354c379aae87b847.zip
Apply upstream patch
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/Manifest4
-rw-r--r--media-tv/mythtv/files/digest-mythtv-0.13-r11
-rw-r--r--media-tv/mythtv/files/tvformat.fix.0.13.diff13
-rw-r--r--media-tv/mythtv/mythtv-0.13-r1.ebuild150
4 files changed, 166 insertions, 2 deletions
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index aa9c8e932572..170dcd3c7ffb 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,8 +1,8 @@
-MD5 b3dbc57362ecff7af5f1249910a441d9 mythtv-0.13-r1.ebuild 4541
+MD5 895a3802ec4d4b4241ce4ceb85c89cf3 mythtv-0.13-r1.ebuild 4544
MD5 a580ceddbe5794beba1e44706de19a02 mythtv-0.12.ebuild 4493
MD5 ff7a010a65450c2f3c3aa1d78c9e3dbb mythtv-0.11.ebuild 2778
MD5 9e7913c1bd9d999c1a33e131766d8e4e mythtv-0.13.ebuild 4487
-MD5 f555753ffc18f69d6e2aa4e929d98c32 ChangeLog 3840
+MD5 416c357e78085b0d7a4fb1bc588d1a81 ChangeLog 4006
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 75594236f281302bcb8f60629e0da65b files/tvformat.fix.0.13.diff 407
MD5 a01439b4ddf480862e31867fc4689698 files/digest-mythtv-0.13-r1 65
diff --git a/media-tv/mythtv/files/digest-mythtv-0.13-r1 b/media-tv/mythtv/files/digest-mythtv-0.13-r1
new file mode 100644
index 000000000000..d64835745f92
--- /dev/null
+++ b/media-tv/mythtv/files/digest-mythtv-0.13-r1
@@ -0,0 +1 @@
+MD5 bdca237336453cf68835063c1a4efa91 mythtv-0.13.tar.bz2 3263341
diff --git a/media-tv/mythtv/files/tvformat.fix.0.13.diff b/media-tv/mythtv/files/tvformat.fix.0.13.diff
new file mode 100644
index 000000000000..4c0f98ad5663
--- /dev/null
+++ b/media-tv/mythtv/files/tvformat.fix.0.13.diff
@@ -0,0 +1,13 @@
+diff -u -d -r1.57 channel.cpp
+--- libs/libmythtv/channel.cpp 5 Dec 2003 01:05:35 -0000 1.57
++++ libs/libmythtv/channel.cpp 14 Dec 2003 03:23:30 -0000
+@@ -342,6 +342,9 @@
+ QString freqid = query.value(1).toString();
+ QString tvformat = query.value(2).toString();
+
++ if (tvformat.isNull() || tvformat.isEmpty())
++ tvformat = "Default";
++
+ pthread_mutex_unlock(&db_lock);
+
+ // Tune
diff --git a/media-tv/mythtv/mythtv-0.13-r1.ebuild b/media-tv/mythtv/mythtv-0.13-r1.ebuild
new file mode 100644
index 000000000000..84cc40fe14a9
--- /dev/null
+++ b/media-tv/mythtv/mythtv-0.13-r1.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.13-r1.ebuild,v 1.1 2003/12/14 11:04:27 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lcd lirc nvidia"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3.1
+ >=media-sound/lame-3.93.1
+ >=media-libs/freetype-2.0
+ >=media-tv/xmltv-0.5.16
+ >=sys-apps/sed-4
+ alsa? ( media-libs/alsa-lib )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )"
+ #dvb? ( media-libs/libdvb )
+
+RDEPEND="${DEPEND}
+ !media-tv/mythfrontend"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs mysql support"
+ fi
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/tvformat.fix.0.13.diff
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
+ -e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
+ -i "settings.pro" || die "enable alsa sed failed"
+ fi
+ # Not quite ready for prime time.
+ #if [ "`use dvb`" ] ; then
+ # sed -e "s:#CONFIG += using_dvb:CONFIG += using_dvb:" \
+ # -e "s:#DEFINES += USING_DVB:DEFINES += USING_DVB:" \
+ # -e "s:#INCLUDEPATH += /usr/src:INCLUDEPATH += /usr:" \
+ # -i "settings.pro" || die "enable dvb sed failed"
+ #fi
+ if [ "`use lcd`" ] ; then
+ sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
+ -i "settings.pro" || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
+ -e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
+ -i "settings.pro" || die "enable xvmc sed failed"
+ fi
+ # Needs a VIA supported kernel driver.
+ #if [ "`use via`" ] ; then
+ # sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
+ # -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
+ # -i "settings.pro" || die "enable lirc sed failed"
+ #fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ econf
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ newbin "setup/setup" "mythsetup"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ insinto /usr/share/mythtv/database
+ doins database/*
+
+ exeinto /usr/share/mythtv
+ doexe "${FILESDIR}/mythfilldatabase.cron"
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/mythbackend.rc6" mythbackend
+ insinto /etc/conf.d
+ newins "${FILESDIR}/mythbackend.conf" mythbackend
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+
+ keepdir /var/{log,run}/mythtv
+}
+
+pkg_postinst() {
+ ewarn "Please note that /usr/share/mythtv/setup has been moved"
+ ewarn "to /usr/bin/mythsetup"
+ echo
+
+ einfo "If this is the first time you install MythTV,"
+ einfo "you need to add /usr/share/mythtv/database/mc.sql"
+ einfo "to your mysql database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/mc.sql'"
+ einfo
+ einfo "Next, you need to run the mythsetup program."
+ einfo "It will ask you some questions about your hardware, and"
+ einfo "then run xmltv's grabber to configure your channels."
+ einfo
+ einfo "Once you have configured your database, you can run"
+ einfo "/usr/bin/mythfilldatabase to populate the schedule"
+ einfo "or copy /usr/share/mythtv/mythfilldatabase.cron to"
+ einfo "/etc/cron.daily for this to happen automatically."
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}