summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-03-26 08:20:51 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-03-26 08:20:51 +0000
commit98e9e47076bbea98fb288cccd9ed0267ffbeff88 (patch)
tree94c0a616697964dc591562a4cd71f6e34a2ac310 /media-tv/mythfrontend
parentMarked ppc stable. (diff)
downloadhistorical-98e9e47076bbea98fb288cccd9ed0267ffbeff88.tar.gz
historical-98e9e47076bbea98fb288cccd9ed0267ffbeff88.tar.bz2
historical-98e9e47076bbea98fb288cccd9ed0267ffbeff88.zip
fixed a DEPEND. remove install of depreciated mysql.txt. added msgs for ieee1394 and nvidia USE flags (bug #81767)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-tv/mythfrontend')
-rw-r--r--media-tv/mythfrontend/ChangeLog6
-rw-r--r--media-tv/mythfrontend/Manifest12
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.17.ebuild24
3 files changed, 28 insertions, 14 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index 13e9b11a84b1..0a275aeceefa 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.31 2005/02/12 17:06:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.32 2005/03/26 08:20:51 cardoe Exp $
+
+ 26 Mar 2005; Doug Goldstein <cardoe@gentoo.org> mythfrontend-0.17.ebuild:
+ fixed a DEPEND. remove install of depreciated mysql.txt. added msgs for
+ ieee1394 and nvidia USE flags (bug #81767)
12 Feb 2005; Doug Goldstein <cardoe@gentoo.org> mythfrontend-0.17.ebuild:
filter problematic CFLAGS
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
index f0d95b092292..83d7499354d2 100644
--- a/media-tv/mythfrontend/Manifest
+++ b/media-tv/mythfrontend/Manifest
@@ -2,15 +2,15 @@
Hash: SHA1
MD5 f62db0df6ee8ee1d4fe7b9c3d74432a7 metadata.xml 222
-MD5 fc6d9193a4a352832bdb84908021f339 ChangeLog 5021
-MD5 497a76c6a7a46f89009fdef2d063e4e9 mythfrontend-0.17.ebuild 5842
+MD5 69dd606fdb61f48c262803ebe01d8ca1 ChangeLog 5217
+MD5 b4f7a9d2d6d8b6eef2ff8621f2ea2898 mythfrontend-0.17.ebuild 6151
MD5 0a31ca05a47f289619d2b8d77cfbff52 mythfrontend-0.16.ebuild 5726
MD5 590c9a6a89442b347c3a5f52d1781351 files/digest-mythfrontend-0.17 66
MD5 fb4505fe7e8b832e115d777bf836d3bc files/digest-mythfrontend-0.16 66
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCDjeP5+pdB4IBr0URAhUeAJ0RJwUfgkc5pkRRDsFsM3RzlZ87KgCfadpM
-QKTDS4Evv19SqJiBQTM4X/4=
-=xfX5
+iD8DBQFCRRt15+pdB4IBr0URAmiyAKCD0VtXI264736x8Sj1fcJl+rVd6QCguFw/
+kHgsmXeHDKu3QSoUZbEV07s=
+=gBx9
-----END PGP SIGNATURE-----
diff --git a/media-tv/mythfrontend/mythfrontend-0.17.ebuild b/media-tv/mythfrontend/mythfrontend-0.17.ebuild
index a336ae35d7c6..10d93201fdb7 100644
--- a/media-tv/mythfrontend/mythfrontend-0.17.ebuild
+++ b/media-tv/mythfrontend/mythfrontend-0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.17.ebuild,v 1.3 2005/02/12 17:06:03 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.17.ebuild,v 1.4 2005/03/26 08:20:51 cardoe Exp $
inherit myth flag-o-matic eutils
@@ -23,7 +23,8 @@ DEPEND=">=media-libs/freetype-2.0
dvb? ( media-libs/libdvb )
lcd? ( app-misc/lcdproc )
lirc? ( app-misc/lirc )
- nvidia? ( media-video/nvidia-glx )"
+ nvidia? ( media-video/nvidia-glx )
+ ieee1394? ( sys-libs/libraw1394 )"
RDEPEND="${DEPEND}
!media-tv/mythtv"
@@ -38,7 +39,20 @@ pkg_setup() {
die "Qt needs MySQL support"
fi
- return 0
+ if use ieee1394; then
+ echo
+ ewarn "If you want to USE 'ieee1394', you need to install libiec61883"
+ ewarn "which is not available in Portage at this time. Do this at your"
+ ewarn "own risk. No Support provided."
+ echo
+ fi
+
+ if use nvidia; then
+ echo
+ ewarn "You enabled the 'nvidia' USE flag, you must have a GeForce 4 or"
+ ewarn "greater to use this. Otherwise, you'll have crashes with MythTV"
+ echo
+ fi
}
setup_pro() {
@@ -170,10 +184,6 @@ src_compile() {
src_install() {
myth_src_install || die "install failed"
- dodir /etc/mythtv
- mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
- dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
-
dodoc keys.txt docs/*.{txt,pdf}
dohtml docs/*.html
}