summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-03 08:50:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-03 08:50:57 +0000
commit657f2dac8be0c8154d5aaf3b664d40170d935312 (patch)
treefaac2e826738be672d5987172eee6225965d6346 /media-sound
parentRemoved older revision. Added patch to no longer use module_param interface r... (diff)
downloadhistorical-657f2dac8be0c8154d5aaf3b664d40170d935312.tar.gz
historical-657f2dac8be0c8154d5aaf3b664d40170d935312.tar.bz2
historical-657f2dac8be0c8154d5aaf3b664d40170d935312.zip
Bump to latest version and remove old ones.
Package-Manager: portage-2.1.1_pre2-r1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-1.4.1.ebuild76
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.13
3 files changed, 86 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index af976ffcebd7..c9b46a2424be 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.143 2006/06/18 22:14:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.144 2006/07/03 08:50:57 flameeyes Exp $
+
+*amarok-1.4.1 (03 Jul 2006)
+
+ 03 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> -amarok-1.4.0a.ebuild,
+ -amarok-1.4.1_beta1.ebuild, +amarok-1.4.1.ebuild:
+ Bump to latest version and remove old ones.
*amarok-1.4.1_beta1 (18 Jun 2006)
diff --git a/media-sound/amarok/amarok-1.4.1.ebuild b/media-sound/amarok/amarok-1.4.1.ebuild
new file mode 100644
index 000000000000..2085faa76262
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.1.ebuild,v 1.1 2006/07/03 08:50:57 flameeyes Exp $
+
+LANGS="az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it ja ka
+km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sl sr sr@Latn sv ta tg th tr uk uz
+zh_CN zh_TW"
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+MY_PV="${PV/_rc/_RC}"
+MY_PV="${MY_PV/_beta/-beta}${PKG_SUFFIX}"
+MY_BASE_PV="${MY_PV/_RC*/}"
+MY_BASE_PV="${MY_BASE_PV/-beta*/}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+SRC_URI="mirror://sourceforge/amarok/${PN}-${MY_PV}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac kde mysql noamazon opengl postgres
+xmms visualization musicbrainz ipod ifp real"
+# kde: enables compilation of the konqueror sidebar plugin
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ musicbrainz? ( >=media-libs/tunepimp-0.3 )
+ >=media-libs/taglib-1.4
+ mysql? ( >=dev-db/mysql-4.0.16 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( media-libs/libgpod )
+ aac? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )"
+
+RDEPEND="${DEPEND}
+ dev-lang/ruby"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.3
+
+src_compile() {
+ append-flags -fno-inline
+
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with musicbrainz)
+ $(use_with ipod libgpod)
+ $(use_with aac mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
diff --git a/media-sound/amarok/files/digest-amarok-1.4.1 b/media-sound/amarok/files/digest-amarok-1.4.1
new file mode 100644
index 000000000000..62510a3d95d4
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.4.1
@@ -0,0 +1,3 @@
+MD5 4ed6e766541c4227d1d8c8eb93d0b891 amarok-1.4.1.tar.bz2 13509939
+RMD160 d9df29c2a2a7b81aabb73c66b83190f0bc109094 amarok-1.4.1.tar.bz2 13509939
+SHA256 dbe4397d041a77f7ded063f50d5cfd2faf0e9efce9b4483589f751c20ff89ccd amarok-1.4.1.tar.bz2 13509939