summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-12 09:37:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-12 09:37:30 +0000
commit0aba92ab327c6cd2892a546764ae022bbedb3df6 (patch)
treeafd73e197a86b076054c1c8fa230abb18e6a34f6 /media-sound/streamripper/streamripper-1.64.6.ebuild
parentx86 stable wrt bug #307839 (diff)
downloadhistorical-0aba92ab327c6cd2892a546764ae022bbedb3df6.tar.gz
historical-0aba92ab327c6cd2892a546764ae022bbedb3df6.tar.bz2
historical-0aba92ab327c6cd2892a546764ae022bbedb3df6.zip
Version bump wrt #308427 by Niels Ole Salscheider.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-sound/streamripper/streamripper-1.64.6.ebuild')
-rw-r--r--media-sound/streamripper/streamripper-1.64.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/streamripper/streamripper-1.64.6.ebuild b/media-sound/streamripper/streamripper-1.64.6.ebuild
new file mode 100644
index 000000000000..287fd49c633b
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.64.6.ebuild,v 1.1 2010/03/12 09:37:30 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="vorbis"
+
+RDEPEND="media-libs/libmad
+ media-libs/faad2
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --without-included-libmad \
+ --without-included-argv \
+ $(use_with vorbis ogg)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES parse_rules.txt README THANKS
+}