summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-11-27 12:22:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-11-27 12:22:12 +0000
commitc28173ab51727092e0201a26a54bb429ae63ac37 (patch)
treee3a6705aea0f9df644552ba7da7b9a62d2317e2d /media-sound/streamripper/streamripper-1.64.0.ebuild
parentVersion bump (diff)
downloadhistorical-c28173ab51727092e0201a26a54bb429ae63ac37.tar.gz
historical-c28173ab51727092e0201a26a54bb429ae63ac37.tar.bz2
historical-c28173ab51727092e0201a26a54bb429ae63ac37.zip
Version bump.
Package-Manager: portage-2.2_rc15/cvs/Linux 2.6.27-gentoo-r3 i686 RepoMan-Options: --force
Diffstat (limited to 'media-sound/streamripper/streamripper-1.64.0.ebuild')
-rw-r--r--media-sound/streamripper/streamripper-1.64.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/streamripper/streamripper-1.64.0.ebuild b/media-sound/streamripper/streamripper-1.64.0.ebuild
new file mode 100644
index 000000000000..52c3451efafc
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.64.0.ebuild,v 1.1 2008/11/27 12:22:12 ssuominen Exp $
+
+inherit eutils
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+RDEPEND="media-libs/libmad
+ media-libs/faad2
+ dev-libs/cdk
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_with vorbis ogg) \
+ --without-included-libmad --without-included-glib \
+ --without-included-argv --without-included-cdk
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc CHANGES README THANKS
+}