summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-06-12 05:06:15 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-06-12 05:06:15 +0000
commitb560db6f92eec10e8f3fa5ce4b75815d2d940d05 (patch)
treeadde3d2024abdc33dae8daf43e8d96d38d2b8cdc /media-sound/nforce-audio
parentNew nforce-audio driver that disables SPDIF output by default. (diff)
downloadhistorical-b560db6f92eec10e8f3fa5ce4b75815d2d940d05.tar.gz
historical-b560db6f92eec10e8f3fa5ce4b75815d2d940d05.tar.bz2
historical-b560db6f92eec10e8f3fa5ce4b75815d2d940d05.zip
New nforce-audio driver that disables SPDIF output by default.
Diffstat (limited to 'media-sound/nforce-audio')
-rw-r--r--media-sound/nforce-audio/Manifest4
-rw-r--r--media-sound/nforce-audio/nforce-audio-1.0.0261.ebuild68
2 files changed, 70 insertions, 2 deletions
diff --git a/media-sound/nforce-audio/Manifest b/media-sound/nforce-audio/Manifest
index 6c743048af89..f3301919e7af 100644
--- a/media-sound/nforce-audio/Manifest
+++ b/media-sound/nforce-audio/Manifest
@@ -1,5 +1,5 @@
-MD5 0a8567f601ec9d064039e18a93078331 nforce-audio-1.0.0261.ebuild 2108
-MD5 7a973e0ed8303c878e89279099638179 ChangeLog 716
+MD5 0a36263bd79c812c7fd39ead1e1b00ce nforce-audio-1.0.0261.ebuild 2111
+MD5 6a4aeb579ec27a663ed37e2c1b75789d ChangeLog 719
MD5 e2158cb9ceebeca6f7c0aca27a6b6d31 nforce-audio-1.0.0256.ebuild 1677
MD5 03580a26c5b10797541c68e7473510bf files/digest-nforce-audio-1.0.0256 73
MD5 c94d06d6f883700d21e346d79589b307 files/digest-nforce-audio-1.0.0261 73
diff --git a/media-sound/nforce-audio/nforce-audio-1.0.0261.ebuild b/media-sound/nforce-audio/nforce-audio-1.0.0261.ebuild
new file mode 100644
index 000000000000..57d70afd5876
--- /dev/null
+++ b/media-sound/nforce-audio/nforce-audio-1.0.0261.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nforce-audio/nforce-audio-1.0.0261.ebuild,v 1.1 2003/06/12 05:06:08 drobbins Exp $
+
+inherit gcc
+
+# Make sure Portage does _NOT_ strip symbols. Need both lines for
+# Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+
+NV_V="${PV/1.0./1.0-}"
+NV_PACKAGE="NVIDIA_nforce-${NV_V}"
+S="${WORKDIR}/nforce"
+DESCRIPTION="Linux kernel module for the NVIDIA's nForce1/2 SoundStorm audio chipset"
+SRC_URI="http://download.nvidia.com/XFree86/nforce/${NV_V}/${NV_PACKAGE}.tar.gz"
+HOMEPAGE="http://www.nvidia.com/"
+
+# The slow needs to be set to $KV to prevent unmerges of
+# modules for other kernels.
+LICENSE="NVIDIA GPL-2"
+SLOT="${KV}"
+KEYWORDS="-* x86"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ cd ${S}/nvaudio
+ make KERNSRC="/usr/src/linux" || die
+}
+
+src_install() {
+ # The driver goes into the standard modules location
+ insinto /lib/modules/${KV}/kernel/drivers/sound
+ doins nvaudio/nvaudio.o
+
+ # Docs
+ dodoc ${S}/ReleaseNotes.html ${S}/GNULicense.txt ${S}/NVLicense.txt
+
+ dodir /etc/modules.d
+ cat > ${D}/etc/modules.d/nvaudio << EOF
+# change spdif_status to 1 to enable digital out; this will cause audio
+# playback to be clamped to 48KHz which can cause some programs to play
+# back audio at the wrong speed.
+options nvaudio spdif_status="0"
+EOF
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ # Update module dependency
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ echo
+ einfo "You need to add \"nvaudio\" to your /etc/modules.autoload to load"
+ einfo "this module when the system is started. Alternatively, you can"
+ einfo "use the 'hotplug' package ('emerge hotplug' then 'rc-update add"
+ einfo "hotplug default') to auto-detect and load \"nvaudio\" on startup."
+ echo
+ einfo "Edit /etc/modules.d/nvaudio and run \"update-modules\" to configure"
+ einfo "the \"nvaudio\" driver to enable digital SPDIF out the next time it"
+ einfo "is loaded."
+}
+