summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-20 20:53:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-20 20:53:04 +0000
commit8b93ce21564ed5ed8c53d7dcc09d817933e27b09 (patch)
tree72b10b5fa007b1e983bcae6ad14ba17c51c39ccb /media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild
parentpam_mount bump (diff)
downloadhistorical-8b93ce21564ed5ed8c53d7dcc09d817933e27b09.tar.gz
historical-8b93ce21564ed5ed8c53d7dcc09d817933e27b09.tar.bz2
historical-8b93ce21564ed5ed8c53d7dcc09d817933e27b09.zip
initial import
Package-Manager: portage-2.1.5
Diffstat (limited to 'media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild')
-rw-r--r--media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild b/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild
new file mode 100644
index 000000000000..3cc1cb841160
--- /dev/null
+++ b/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack-smf-utils/jack-smf-utils-1.0.ebuild,v 1.1 2008/05/20 20:53:04 aballier Exp $
+
+DESCRIPTION="Utilities for MIDI streams and files using Jack MIDI"
+HOMEPAGE="http://pin.if.uz.zgora.pl/~trasz/jack-smf-utils/"
+SRC_URI="http://pin.if.uz.zgora.pl/~trasz/jack-smf-utils/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lash readline"
+
+RDEPEND="readline? ( sys-libs/readline )
+ >=dev-libs/glib-2.2
+ >=media-sound/jack-audio-connection-kit-0.102
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+
+src_compile() {
+ econf $(use_with readline) \
+ $(use_with lash)
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO
+}