summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-20 19:42:26 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-20 19:42:26 +0000
commit95e23f1420c4e4bed269601918b91e926a8f3fa6 (patch)
treea1df622bdc5c7a4a9a484c68ce9453d7dd641542 /media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild
parentFixed DEOEND misspelling (diff)
downloadhistorical-95e23f1420c4e4bed269601918b91e926a8f3fa6.tar.gz
historical-95e23f1420c4e4bed269601918b91e926a8f3fa6.tar.bz2
historical-95e23f1420c4e4bed269601918b91e926a8f3fa6.zip
After much headache. This is finally installable on gentoo. w00t!
The research into this solved some fltk+gcc3 issues as well. So anyway, yeah... on to committing!
Diffstat (limited to 'media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild')
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild
new file mode 100644
index 000000000000..2486c8fb695f
--- /dev/null
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild,v 1.1 2002/09/20 19:42:26 raker Exp $
+
+NATIVE_VER=0.9.0rc1-2
+S=${WORKDIR}/${PN}-${NATIVE_VER}
+
+DESCRIPTION="AlsaMixerGui - a FLTK based amixer Frontend"
+HOMEPAGE="http://www.iua.upf.es/~mdeboer/projects/alsamixergui/"
+SRC_URI="ftp://www.iua.upf.es/pub/mdeboer/projects/alsamixergui/${PN}-${NATIVE_VER}.tar.gz"
+
+DEPEND=">=media-sound/alsa-driver-0.9.0_rc1
+ >=media-sound/alsa-lib-0.9.0_rc1
+ >=media-sound/alsa-utils-0.9.0_rc1
+ >=x11-libs/fltk-1.1.0_rc6"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/fltk-1.1+gcc3.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ export LDFLAGS="-L/usr/lib/fltk-1.1"
+ export CPPFLAGS="-I/usr/include/fltk-1.1"
+
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc COPYING README AUTHORS ChangeLog
+
+}