summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-10 16:39:37 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-10 16:39:37 +0000
commita4ed930eba6a6a29006976e3d26ccec5f5b776a6 (patch)
tree9439721094cecd3e856221a16bee1b2cd2f5b4e5 /media-sound/alsa-utils/alsa-utils-1.0.1.ebuild
parentcleanup (diff)
downloadhistorical-a4ed930eba6a6a29006976e3d26ccec5f5b776a6.tar.gz
historical-a4ed930eba6a6a29006976e3d26ccec5f5b776a6.tar.bz2
historical-a4ed930eba6a6a29006976e3d26ccec5f5b776a6.zip
Version bumped.
Diffstat (limited to 'media-sound/alsa-utils/alsa-utils-1.0.1.ebuild')
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.1.ebuild
new file mode 100644
index 000000000000..28f3fe19d250
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.1.ebuild,v 1.1 2004/01/10 16:39:37 mholzer Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+DEPEND=">=sys-libs/ncurses-5.1
+ >=media-libs/alsa-lib-1.0.0_rc2"
+
+SLOT="0.9"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc64"
+
+MY_P=${P/_rc/rc}
+#SRC_URI="ftp://ftp.alsa-project.org/pub/utils/${MY_P}.tar.bz2"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+RESTRICT="nomirror"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ dodir /etc/init.d
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run update-modules. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && update-modules"
+ echo
+ ewarn "Pausing for 20 seconds to give you time to read..."
+ sleep 20
+}