summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-07-13 02:13:32 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-07-13 02:13:32 +0000
commit7376f98432063d874b5dec072db805e009b30fb2 (patch)
tree1649b5fe70471ebc5b7f49125f87e3c217454050 /media-sound/alsa-driver
parent- wasn't installing the small icons. does now. (diff)
downloadhistorical-7376f98432063d874b5dec072db805e009b30fb2.tar.gz
historical-7376f98432063d874b5dec072db805e009b30fb2.tar.bz2
historical-7376f98432063d874b5dec072db805e009b30fb2.zip
alsa externalized again, as are the mosix-user utilities.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.5.11.ebuild59
-rw-r--r--media-sound/alsa-driver/files/alsa17
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.5.111
3 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild b/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild
new file mode 100644
index 000000000000..dafbfb8e4d2c
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild,v 1.1 2001/07/13 02:13:32 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Advanced Linux Sound Architecture modules"
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/alsa-driver-${PV}.tar.bz2"
+HOMEPAGE="http://www.alsa-project.org"
+
+#add kernel includes dependency when we have one
+DEPEND="sys-devel/autoconf virtual/glibc sys-kernel/linux-sources"
+PROVIDE="virtual/alsa"
+
+#might be good to roll this into Portage at some point.
+KV=`readlink /usr/src/linux`
+if [ $? -ne 0 ]
+then
+ echo
+ echo "/usr/src/linux symlink does not exist; cannot continue."
+ echo
+ exit 1
+fi
+#alsa-driver will compile modules for the kernel pointed to by /usr/src/linux
+KV=${KV/linux-/}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure.in configure.in.orig
+ sed -e 's/-m.86//g' configure.in.orig > configure.in
+ autoconf
+}
+
+src_compile() {
+ try ./configure --with-kernel=\"${ROOT}usr/src/linux-${KV}\" --with-isapnp=yes --with-sequencer=yes --with-oss=yes --with-cards=all
+ try emake
+}
+
+src_install () {
+ #point this to the kernel headers in the future, not the kernel sources
+ insinto /usr/src/linux/include/linux
+ cd ${S}/include
+ doins asound.h asoundid.h asequencer.h ainstr_*.h
+ dodoc INSTALL FAQ
+ dodir /lib/modules/${KV}/misc
+ cp ${S}/modules/*.o ${D}/lib/modules/${KV}/misc
+ dodir /etc/modutils
+ insinto /etc/modutils
+ doins ${FILESDIR}/alsa
+ #this is the new modular modules system (from Debian) :)
+}
+
+pkg_postinst() {
+ if [ -e /sbin/update-modules ]
+ then
+ /sbin/update-modules
+ fi
+}
diff --git a/media-sound/alsa-driver/files/alsa b/media-sound/alsa-driver/files/alsa
new file mode 100644
index 000000000000..e65df04f4799
--- /dev/null
+++ b/media-sound/alsa-driver/files/alsa
@@ -0,0 +1,17 @@
+# ALSA portion
+alias char-major-116 snd
+# OSS/Free portion
+alias char-major-14 soundcore
+
+# OSS/Free portion - card #1
+alias sound-service-0-0 snd-mixer-oss
+alias sound-service-0-1 snd-seq-oss
+alias sound-service-0-3 snd-pcm-oss
+alias sound-service-0-8 snd-seq-oss
+alias sound-service-0-12 snd-pcm-oss
+
+#customize the lines below to allow for demand-loading of modules
+#options snd snd_major=116 snd_cards_limit=1
+#alias snd-card-0 snd-card-ens1371
+#options snd-card-ens1371 snd_index=0
+#alias sound-slot-0 snd-card-0
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.5.11 b/media-sound/alsa-driver/files/digest-alsa-driver-0.5.11
new file mode 100644
index 000000000000..f4f8e99fdca4
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.5.11
@@ -0,0 +1 @@
+MD5 ff807499928379c4274a307855b9eeeb alsa-driver-0.5.11.tar.bz2