summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-03 00:34:30 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-03 00:34:30 +0000
commit1d861ddf011f48c215b50d482051f53bcb06ce7e (patch)
treec917d4e7615083a6595591095bef9043ae2bafcb /media-sound/alsa-driver
parentInitial ebuild submitted by oyvind.repvik@siemenssg.com (?yvind (diff)
downloadhistorical-1d861ddf011f48c215b50d482051f53bcb06ce7e.tar.gz
historical-1d861ddf011f48c215b50d482051f53bcb06ce7e.tar.bz2
historical-1d861ddf011f48c215b50d482051f53bcb06ce7e.zip
Added a hack to work around breakage if a user has /etc/rc.d/init.d
directory on the system. Closes bug #2363.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r4.ebuild74
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r41
3 files changed, 82 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 87a80a88088c..65e7a0eb7908 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.6 2002/04/28 17:18:10 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.7 2002/05/03 00:34:30 agenkin Exp $
*alsa-driver-0.9.0_rc1 (27 Apr 2002)
+ 2 May 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-driver-0.9.0_rc1-r4.ebuild :
+
+ Added a hack to work around compilation breakage if a user has
+ /etc/rc.d/init.d directory.
+
28 Apr 2002; Arcady Genkin <agenkin@thpoon.com>
alsa-driver-0.9.0_rc1-r3.ebuild :
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r4.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r4.ebuild
new file mode 100644
index 000000000000..5cb8d1585510
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r4.ebuild,v 1.1 2002/05/03 00:34:30 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment variable accordingly
+[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="sys-devel/autoconf
+ virtual/glibc"
+PROVIDE="virtual/alsa"
+
+
+src_unpack() {
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ unpack ${A}
+ cd ${S}
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+}
+
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux-${KV}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards=${ALSA_CARDS} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You might want to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r4 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r4
new file mode 100644
index 000000000000..ab82b0c07726
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc1-r4
@@ -0,0 +1 @@
+MD5 440feeb7a0932a9f40a059fe78b3d6b2 alsa-driver-0.9.0rc1.tar.bz2 1103418