summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-08-25 22:17:04 +0000
committerChris White <chriswhite@gentoo.org>2005-08-25 22:17:04 +0000
commit983926a0f5198cfbd918be364ab37a9b262bd2d4 (patch)
tree14184dc2fa17f4e57f05528fbef52a300a07ed0b /media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
parentia64 love (diff)
downloadhistorical-983926a0f5198cfbd918be364ab37a9b262bd2d4.tar.gz
historical-983926a0f5198cfbd918be364ab37a9b262bd2d4.tar.bz2
historical-983926a0f5198cfbd918be364ab37a9b262bd2d4.zip
Converted to linux-info.eclass methods so as to stop warning message spam. Only remove old kernel sound modules if they actually exist (prevents silly directory not found warnings with find).
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild')
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
index a54a31eae2af..5a9321eaeb6d 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild,v 1.8 2005/07/21 03:41:06 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild,v 1.9 2005/08/25 22:17:04 chriswhite Exp $
inherit linux-mod flag-o-matic eutils
@@ -80,9 +80,9 @@ src_compile() {
# linux-mod_src_compile doesn't work well with alsa
# -j1 : see bug #71028
- set_arch_to_kernel
+ ARCH=$(tc-arch-kernel)
emake -j1 || die "Make Failed"
- set_arch_to_portage
+ ARCH=$(tc-arch)
if use doc;
then
@@ -148,7 +148,7 @@ pkg_postinst() {
einfo "Check out the ALSA installation guide availible at the following URL:"
einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
- if kernel_is 2 6; then
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
# Cleanup if they had older alsa installed
for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}