summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-08-16 04:47:51 +0000
committerJon Hood <squinky86@gentoo.org>2004-08-16 04:47:51 +0000
commit67cda1a1d853ce7561b098639bad37c8e7669bcf (patch)
tree3dcffabf67775544307661353e60efa2c53260e5 /media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
parentwww-proxy/tinyproxy moved (diff)
downloadhistorical-67cda1a1d853ce7561b098639bad37c8e7669bcf.tar.gz
historical-67cda1a1d853ce7561b098639bad37c8e7669bcf.tar.bz2
historical-67cda1a1d853ce7561b098639bad37c8e7669bcf.zip
apply fix for #51832
Diffstat (limited to 'media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild')
-rw-r--r--media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild b/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
index a9057d1ebafb..9f2ca8bcb1d2 100644
--- a/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
+++ b/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild,v 1.3 2004/07/13 08:42:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/streamtuner-python/streamtuner-python-0.1.2.ebuild,v 1.4 2004/08/16 04:47:51 squinky86 Exp $
+
+inherit eutils
DESCRIPTION="A plugin for Streamtuner that provides an embedded Python interpreter."
SRC_URI="http://savannah.nongnu.org/download/streamtuner/${P}.tar.gz"
@@ -12,9 +14,15 @@ KEYWORDS="x86 ~ppc ~amd64 ~sparc"
LICENSE="BSD"
DEPEND=">=net-misc/streamtuner-0.12.0
- >=dev-lang/python-2.0"
+ >=dev-lang/python-2.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-configure.patch
+}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README INSTALL
}