summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:34:30 +0000
commitafc904ac0228783d2cb5e882169be5c5ad579f5b (patch)
treefed52e0423ca47affb5be1985e0b2a07f7bcd4f5 /media-plugins/mythweather
parentBump to version 0.12. Add support for alsa, lirc, and vcd. (diff)
downloadhistorical-afc904ac0228783d2cb5e882169be5c5ad579f5b.tar.gz
historical-afc904ac0228783d2cb5e882169be5c5ad579f5b.tar.bz2
historical-afc904ac0228783d2cb5e882169be5c5ad579f5b.zip
Bump to version 0.12.
Diffstat (limited to 'media-plugins/mythweather')
-rw-r--r--media-plugins/mythweather/ChangeLog7
-rw-r--r--media-plugins/mythweather/Manifest4
-rw-r--r--media-plugins/mythweather/files/digest-mythweather-0.121
-rw-r--r--media-plugins/mythweather/mythweather-0.12.ebuild39
4 files changed, 49 insertions, 2 deletions
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index c19b58b53685..9ff01125c0c0 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.5 2003/09/17 06:29:50 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.6 2003/10/20 03:34:29 max Exp $
+
+*mythweather-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythweather-0.12.ebuild:
+ Bump to version 0.12.
16 Sep 2003; Max Kalika <max@gentoo.org> mythweather-0.10.ebuild,
mythweather-0.11.ebuild:
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 958f21675523..03d03fe5b776 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,6 +1,8 @@
+MD5 5230ef18d7189354c4925becd1247dc0 mythweather-0.12.ebuild 962
MD5 103f2dc2a77568b205f86d9f8a21e4a8 mythweather-0.11.ebuild 972
MD5 d7ca666cb6cccf06ea43cd7a48ae62ee mythweather-0.10.ebuild 1005
-MD5 aebc302937c8337e949829ef751bb0e7 ChangeLog 1460
+MD5 8d11231e8a232a429760dc93f1567cc5 ChangeLog 1586
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 09666f4a410bc5eda6781edd029505f7 files/digest-mythweather-0.10 69
MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
+MD5 916ba5d7844b0abae782627b8d1a21fe files/digest-mythweather-0.12 69
diff --git a/media-plugins/mythweather/files/digest-mythweather-0.12 b/media-plugins/mythweather/files/digest-mythweather-0.12
new file mode 100644
index 000000000000..14f49fcf11a2
--- /dev/null
+++ b/media-plugins/mythweather/files/digest-mythweather-0.12
@@ -0,0 +1 @@
+MD5 8daad867e4eaf04506401975647d6144 mythweather-0.12.tar.bz2 824577
diff --git a/media-plugins/mythweather/mythweather-0.12.ebuild b/media-plugins/mythweather/mythweather-0.12.ebuild
new file mode 100644
index 000000000000..e6cb52656f81
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.12.ebuild,v 1.1 2003/10/20 03:34:29 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}