summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-22 17:58:33 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-22 17:58:33 +0000
commit1917cfc40d84b18137dcf997364d04b966c7cc90 (patch)
treeea6256c30b4b35036fbca020b960d969139a652c /media-libs
parentUSE=nocxx (diff)
downloadhistorical-1917cfc40d84b18137dcf997364d04b966c7cc90.tar.gz
historical-1917cfc40d84b18137dcf997364d04b966c7cc90.tar.bz2
historical-1917cfc40d84b18137dcf997364d04b966c7cc90.zip
Workaround for gcc-3.4 bug with -Os closes bug #68479.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvorbis/ChangeLog6
-rw-r--r--media-libs/libvorbis/Manifest14
-rw-r--r--media-libs/libvorbis/libvorbis-1.1.0.ebuild7
3 files changed, 21 insertions, 6 deletions
diff --git a/media-libs/libvorbis/ChangeLog b/media-libs/libvorbis/ChangeLog
index eb55f79534fd..813517bc3496 100644
--- a/media-libs/libvorbis/ChangeLog
+++ b/media-libs/libvorbis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libvorbis
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.43 2004/10/20 13:57:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.44 2004/10/22 17:58:33 eradicator Exp $
+
+ 22 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ libvorbis-1.1.0.ebuild:
+ Workaround for gcc-3.4 bug with -Os closes bug #68479.
20 Oct 2004; Guy Martin <gmsoft@gentoo.org> libvorbis-1.1.0.ebuild:
Stable on hppa.
diff --git a/media-libs/libvorbis/Manifest b/media-libs/libvorbis/Manifest
index 10ea58628960..13398fc5ef4a 100644
--- a/media-libs/libvorbis/Manifest
+++ b/media-libs/libvorbis/Manifest
@@ -1,6 +1,16 @@
-MD5 51c10e50e48a65bf508552d70acd8ec2 ChangeLog 6240
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 7af717da68974d6bfd53a2ee58269435 libvorbis-1.0.1-r2.ebuild 2396
-MD5 f7f0c6d11a7280db054a967451a9cc85 libvorbis-1.1.0.ebuild 2501
MD5 527dcfe3ce0f0b53c6b6aa8b82eb930c metadata.xml 252
+MD5 0060354dd5e0a437099df3425ecd611e ChangeLog 6385
+MD5 5ac8263030183814980fef90c217865e libvorbis-1.1.0.ebuild 2560
MD5 fa4a831d30804a9840476e2e65c42241 files/digest-libvorbis-1.0.1-r2 68
MD5 386f4c2e5d4e73b573479df6fdbcbf4e files/digest-libvorbis-1.1.0 68
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBeUs6ArHZZzCEUG0RAmM4AJ9DO4SweJbzAAjGTRxaxBJxbdQw3wCfbSuJ
+pvp5WKV5XlmI7haPBtnoWUQ=
+=j6bJ
+-----END PGP SIGNATURE-----
diff --git a/media-libs/libvorbis/libvorbis-1.1.0.ebuild b/media-libs/libvorbis/libvorbis-1.1.0.ebuild
index e4037fa2993a..09912e28285f 100644
--- a/media-libs/libvorbis/libvorbis-1.1.0.ebuild
+++ b/media-libs/libvorbis/libvorbis-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.0.ebuild,v 1.4 2004/10/20 13:57:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.0.ebuild,v 1.5 2004/10/22 17:58:33 eradicator Exp $
IUSE=""
@@ -24,9 +24,7 @@ src_unpack() {
# Fix a gcc crash. With the new atexit patch to gcc, it
# seems it does not handle -mno-ieee-fp very well.
sed -i -e "s:-mno-ieee-fp::g" configure
-}
-src_compile() {
# Fixes some strange sed-, libtool- and ranlib-errors on
# Mac OS X
if use macos || use ppc-macos; then
@@ -34,9 +32,12 @@ src_compile() {
else
elibtoolize
fi
+}
+src_compile() {
# Cannot compile with sse2 support it would seem #36104
use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
+ [ "`gcc-version`" == "3.4" ] && replace-flags -Os -O2
# take out -fomit-frame-pointer from CFLAGS if k6-2
is-flag -march=k6-3 && filter-flags -fomit-frame-pointer