summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-08-17 20:27:46 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-08-17 20:27:46 +0000
commita45fd69eea1f4e97131563dd8c411f9421e5955e (patch)
tree1d48d57bfd91cf5b3a344726eb523e1347e298aa /media-libs/swfdec/swfdec-0.6.8.ebuild
parentRemove sys-fs/e2fsprogs from the system set in order to allow (diff)
downloadhistorical-a45fd69eea1f4e97131563dd8c411f9421e5955e.tar.gz
historical-a45fd69eea1f4e97131563dd8c411f9421e5955e.tar.bz2
historical-a45fd69eea1f4e97131563dd8c411f9421e5955e.zip
Fix automagic detection of audio if no audio backend is selected in USE (bug #233602).
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.2 i686
Diffstat (limited to 'media-libs/swfdec/swfdec-0.6.8.ebuild')
-rw-r--r--media-libs/swfdec/swfdec-0.6.8.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/media-libs/swfdec/swfdec-0.6.8.ebuild b/media-libs/swfdec/swfdec-0.6.8.ebuild
index f23d21ba8bdc..620e3b4a754f 100644
--- a/media-libs/swfdec/swfdec-0.6.8.ebuild
+++ b/media-libs/swfdec/swfdec-0.6.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/swfdec-0.6.8.ebuild,v 1.1 2008/07/30 15:39:06 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/swfdec-0.6.8.ebuild,v 1.2 2008/08/17 20:27:46 ford_prefect Exp $
EAPI=1
-inherit eutils versionator confutils
+inherit eutils versionator
MY_PV=$(get_version_component_range 1-2)
DESCRIPTION="Macromedia Flash decoding library"
@@ -51,16 +51,19 @@ pkg_setup() {
ewarn "as such it requires the 'gstreamer' USE flag to be enabled."
fi
- confutils_use_conflict oss alsa pulseaudio
+ if use alsa && use pulseaudio; then
+ ewarn
+ ewarn "Pulseaudio and ALSA selected. Selecting mature ALSA backend."
+ fi
}
src_compile() {
- local myconf=
-
- #--with-audio=[auto/alsa/oss/none]
- use oss && myconf="${myconf} --with-audio=oss"
- use pulseaudio && myconf="${myconf} --with-audio=pa"
- use alsa && myconf="${myconf} --with-audio=alsa"
+ # Backend logic is from configure.ac:
+ # alsa > pulseaudio > oss
+ local audio="none"
+ use oss && audio="oss"
+ use pulseaudio && audio="pa"
+ use alsa && audio="alsa"
# bug #216009
# avoid writing to /root/.gstreamer-0.10/registry.xml
@@ -74,7 +77,7 @@ src_compile() {
$(use_enable gtk) \
--disable-ffmpeg \
--disable-mad \
- ${myconf} || die "configure failed"
+ --with-audio=${audio} || die "configure failed"
# bug #216284 image tests are not ready yet
cat >test/image/Makefile <<EOF