summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-21 22:03:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-21 22:03:30 +0000
commit2ecf9b94befc55ea20ce64b23f89f26f13d542df (patch)
treeb838e022600fd3c008e46803f5c84a74d80ab2c1 /media-libs/slv2/slv2-0.5.0.ebuild
parentx86 stable, bug #206764 (diff)
downloadhistorical-2ecf9b94befc55ea20ce64b23f89f26f13d542df.tar.gz
historical-2ecf9b94befc55ea20ce64b23f89f26f13d542df.tar.bz2
historical-2ecf9b94befc55ea20ce64b23f89f26f13d542df.zip
version bump
Package-Manager: portage-2.1.4
Diffstat (limited to 'media-libs/slv2/slv2-0.5.0.ebuild')
-rw-r--r--media-libs/slv2/slv2-0.5.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/slv2/slv2-0.5.0.ebuild b/media-libs/slv2/slv2-0.5.0.ebuild
new file mode 100644
index 000000000000..406b025a1185
--- /dev/null
+++ b/media-libs/slv2/slv2-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/slv2-0.5.0.ebuild,v 1.1 2008/01/21 22:03:29 aballier Exp $
+
+DESCRIPTION="A library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://wiki.drobilla.net/SLV2"
+SRC_URI="http://download.drobilla.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jack"
+
+RDEPEND="dev-libs/redland
+ media-libs/raptor
+ jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/lv2core"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable doc documentation)
+
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "creating documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README ChangeLog
+ doman doc/man/man3/*
+ use doc && dohtml doc/html/*
+}