summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-12 21:35:43 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-12 21:35:43 +0000
commit9c46eac7e6cf068f741d75eb64f10c11b9f4587a (patch)
tree57f05353f5ec923331492d7e03f0cfb04d9d3976 /media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild
parent2.2.0_alpha117 version bump. This includes all of the fixes in 2.1.11.6. (diff)
downloadhistorical-9c46eac7e6cf068f741d75eb64f10c11b9f4587a.tar.gz
historical-9c46eac7e6cf068f741d75eb64f10c11b9f4587a.tar.bz2
historical-9c46eac7e6cf068f741d75eb64f10c11b9f4587a.zip
New package, initial commit. Import from kde overlay.
Package-Manager: portage-2.2.0_alpha117/cvs/Linux x86_64
Diffstat (limited to 'media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild')
-rw-r--r--media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild b/media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild
new file mode 100644
index 000000000000..ca1cc3772716
--- /dev/null
+++ b/media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qt-gstreamer/qt-gstreamer-0.10.2.ebuild,v 1.1 2012/07/12 21:35:43 johu Exp $
+
+EAPI=4
+
+QT_MINIMAL="4.7.0"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+else
+ GIT_ECLASS="git-2"
+ EGIT_REPO_URI="git://anongit.freedesktop.org/gstreamer/${PN}"
+ KEYWORDS=""
+fi
+
+inherit cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="QtGStreamer provides C++ bindings for GStreamer with a Qt-style API."
+HOMEPAGE="http://gstreamer.freedesktop.org/wiki/QtGStreamer"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/glib
+ >=dev-util/boost-build-1.40
+ >=media-libs/gstreamer-0.10.33
+ >=media-libs/gst-plugins-base-0.10.33
+ >=x11-libs/qt-core-${QT_MINIMAL}:4
+ >=x11-libs/qt-declarative-${QT_MINIMAL}:4
+ >=x11-libs/qt-gui-${QT_MINIMAL}:4
+ >=x11-libs/qt-opengl-${QT_MINIMAL}:4
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=x11-libs/qt-test-${QT_MINIMAL}:4 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test QTGSTREAMER_TESTS)
+ )
+
+ cmake-utils_src_configure
+}