summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-04-19 21:49:08 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-04-19 21:49:08 +0000
commit49ae44123eac939fb286f714b9a1cf9d5bc7d5db (patch)
treef482260588c5a7d9c594b2a14e23c4f4b8ded35f /media-libs/libwmf
parentremoved older ebuilds (diff)
downloadhistorical-49ae44123eac939fb286f714b9a1cf9d5bc7d5db.tar.gz
historical-49ae44123eac939fb286f714b9a1cf9d5bc7d5db.tar.bz2
historical-49ae44123eac939fb286f714b9a1cf9d5bc7d5db.zip
added libwmf - a library to convert windows wmf files to something else.
Diffstat (limited to 'media-libs/libwmf')
-rw-r--r--media-libs/libwmf/ChangeLog18
-rw-r--r--media-libs/libwmf/files/digest-libwmf-0.2.21
-rw-r--r--media-libs/libwmf/libwmf-0.2.2.ebuild50
3 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/libwmf/ChangeLog b/media-libs/libwmf/ChangeLog
new file mode 100644
index 000000000000..a45cf0179166
--- /dev/null
+++ b/media-libs/libwmf/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for dev-libs/libwmf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp
+
+*libwmf-0.2.2-pre1 (7 Feb 2002)
+
+ 19 Apr 2002; G.Shapovalov <georges@its.caltech.edu> all_files :
+
+ initial release. This library is necessary for building wv, so that it can
+ correctly parse MSWord files containing wmf images.
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-libs/libwmf/files/digest-libwmf-0.2.2 b/media-libs/libwmf/files/digest-libwmf-0.2.2
new file mode 100644
index 000000000000..48e2bbd1d9fa
--- /dev/null
+++ b/media-libs/libwmf/files/digest-libwmf-0.2.2
@@ -0,0 +1 @@
+MD5 49fc8a235b09cdb62f0cf03ec514669f libwmf-0.2.2.tar.gz 1635344
diff --git a/media-libs/libwmf/libwmf-0.2.2.ebuild b/media-libs/libwmf/libwmf-0.2.2.ebuild
new file mode 100644
index 000000000000..4c1a27d73edd
--- /dev/null
+++ b/media-libs/libwmf/libwmf-0.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License
+# Maintainer: George Shapovalov <georges@cco.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/dev-libs/libwmf/libwmf-0.2.2.ebuild,v 1.2 2002/01/24 19:40:43 karltk Exp
+
+#The configure script finds the 5.50 ghostscript Fontmap file while run.
+#This will probably work, especially since the real one (6.50) in this case
+#is empty. However beware in case there is any trouble
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="library for converting WMF files"
+SRC_URI="http://prdownloads.sourceforge.net/wvware/libwmf-0.2.2.tar.gz"
+HOMEPAGE="http://www.wvware.com/libwmf.html"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.2
+ >=app-text/ghostscript-6.50
+ dev-libs/expat
+ dev-libs/libxml2
+ >=media-libs/freetype-2.0.1
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/jpeg"
+# plotutils are not really supported yet, so looks like that's it
+
+RDEPEND=""
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-gsfontdir=/usr/share/ghostscript/fonts \
+ --with-fontdir=/usr/share/libwmf/fonts/ \
+ --with-docdir=${D}/usr/share/doc/${PF} || die "./configure failed"
+
+ make || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ fontdir=${D}/usr/share/libwmf/fonts/ \
+ install || die
+}