summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Toomsalu <frame@gentoo.org>2003-06-26 12:32:30 +0000
committerAndres Toomsalu <frame@gentoo.org>2003-06-26 12:32:30 +0000
commit8d1c140e062dce2911ac311ac7b3e02d26adc43f (patch)
treef090f57aeaad85fd4596e1f53c0d585d220eb707 /media-libs/libaudiooss/libaudiooss-1.1.0-r1.ebuild
parentInitial import ebuild submitted by Bret Towe (diff)
downloadhistorical-8d1c140e062dce2911ac311ac7b3e02d26adc43f.tar.gz
historical-8d1c140e062dce2911ac311ac7b3e02d26adc43f.tar.bz2
historical-8d1c140e062dce2911ac311ac7b3e02d26adc43f.zip
Initial import ebuild submitted by Bret Towe
Diffstat (limited to 'media-libs/libaudiooss/libaudiooss-1.1.0-r1.ebuild')
-rw-r--r--media-libs/libaudiooss/libaudiooss-1.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libaudiooss/libaudiooss-1.1.0-r1.ebuild b/media-libs/libaudiooss/libaudiooss-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3af8cdcf0e44
--- /dev/null
+++ b/media-libs/libaudiooss/libaudiooss-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+IUSE=""
+
+S=${WORKDIR}/audiooss-${PV}
+HOMEPAGE="http://romeo.skybert.no/~erik/linux.html"
+DESCRIPTION="Transparent OSS emulation on top of the Network Audio System"
+SRC_URI="http://romeo.skybert.no/~erik/audiooss-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ media-libs/nas"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ xmkmf -a || die
+ mv Makefile Makefile.old
+ sed -e "s:.*CDEBUGFLAGS =.*:CDEBUGFLAGS=${CFLAGS}:" \
+ Makefile.old > Makefile
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+}