summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-11 21:11:17 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-11 21:11:17 +0000
commit678e801a0f7d988d6619c9485912928dfc4b8a1b (patch)
tree0e1775442335a0d090be00196e9cf7ccbdd624d1 /media-libs/lastfmlib/lastfmlib-0.3.0.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-678e801a0f7d988d6619c9485912928dfc4b8a1b.tar.gz
historical-678e801a0f7d988d6619c9485912928dfc4b8a1b.tar.bz2
historical-678e801a0f7d988d6619c9485912928dfc4b8a1b.zip
Initial commit. Fixes bug 275929
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'media-libs/lastfmlib/lastfmlib-0.3.0.ebuild')
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild b/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild
new file mode 100644
index 000000000000..de0df2748f32
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild,v 1.1 2009/07/11 21:11:17 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="http://code.google.com/p/lastfmlib"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="syslog test debug"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable syslog logging) \
+ $(use_enable debug) \
+ --disable-unittests || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
+}